Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

SQL Server does not allow remote connections.". Expand / Collapse
Author
Message
Posted Tuesday, August 12, 2008 12:28 AM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Today @ 1:11 AM
Points: 2,840, Visits: 3,976
HI,

I HAVE LINKED SERVER ....
I M EXECUTING A FROM SERVER1

select * from [SERVER2\dev].COMPANYNAME_prod.sys.sysobjects

ITS GIVING ERROR:



OLE DB provider "SQLNCLI" for linked server "SERVER2\dev" returned message "Login timeout expired".
OLE DB provider "SQLNCLI" for linked server "SERVER2\dev" returned message "An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections.".
Msg 65535, Level 16, State 1, Line 0
SQL Network Interfaces: Error Locating Server/Instance Specified [xFFFFFFFF].


PEASE SUGGEST ANY SOLUTION


-------Bhuvnesh----------
I work only to learn Sql Server...though my company pays me for getting their stuff done
Post #550760
Posted Tuesday, August 12, 2008 2:26 AM


Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Saturday, February 23, 2013 11:51 PM
Points: 9, Visits: 110
Hi,

Try these steps.

Start > Programs > SqlServer2005 > ConfigurationTools > SQLServer SurfaceArea Configuration >Click Surface Area Configuration For Services and Connections > Click Remote Connections > Click Local and Remote connections and within that Select Using both TCP/IP and named Pipes > Apply > Ok...

Hope this helps....:)


Best Regards,
TALIB ALI KHAN
MCTS
http://www.onlineasp.net
Post #550799
Posted Tuesday, August 12, 2008 2:33 AM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Today @ 1:11 AM
Points: 2,840, Visits: 3,976
thanks for your suggestion but it is already enabled.....any oher IDEA?

-------Bhuvnesh----------
I work only to learn Sql Server...though my company pays me for getting their stuff done
Post #550800
Posted Tuesday, August 12, 2008 3:21 AM
SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Friday, May 30, 2014 6:27 PM
Points: 2,808, Visits: 7,175
Enable SQL browser on the SQL server..
Post #550820
Posted Tuesday, August 12, 2008 3:28 AM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Today @ 1:11 AM
Points: 2,840, Visits: 3,976
Already Enabled

-------Bhuvnesh----------
I work only to learn Sql Server...though my company pays me for getting their stuff done
Post #550824
Posted Monday, May 5, 2014 10:51 AM
Old Hand

Old HandOld HandOld HandOld HandOld HandOld HandOld HandOld Hand

Group: General Forum Members
Last Login: Monday, November 17, 2014 2:08 PM
Points: 321, Visits: 1,290
hi Guys ,
Working on same error any workaround please?


Aim to inspire rather than to teach.
SQL Server DBA
Post #1567624
Posted Monday, August 11, 2014 11:33 PM
SSC Journeyman

SSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC Journeyman

Group: General Forum Members
Last Login: Sunday, November 23, 2014 11:05 PM
Points: 81, Visits: 189
have you tested your linked server? if not (Goto->server objects->linked servers->right click yourlinkedserver and click test connection)
if the test is successfull you have access to your remote connection. if the test failed. try to create a .udl file and check you can connect to the remote server.
Also one thing you need to check is the remote server has enable "allow remote connection to this server"
you can check this under instance properties->connections also check the remote query timeout to more than 5 minutes or to 0(unlimited).
Please let me know the status after this.
Post #1602148
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse