Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase 12345»»»

Reporting Services Login Box always prompting when deploying my report Expand / Collapse
Author
Message
Posted Wednesday, June 25, 2008 4:34 AM


SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, September 4, 2009 1:18 AM
Points: 34, Visits: 158
Hi to all,
I have a problem in deploying my report in BIDS because there's a Reporting Services Login box that keeps prompting whenever I deploy my report, asking for Username and Password. I didn't set or configure a password when I installed the SQL server 2005.. I did everything search the net, configure IIS through properties of reportserver, change it's Directory Security and edit the Anonymous access and aunthentication control but no luck.

Please help...
Post #523146
Posted Wednesday, June 25, 2008 8:51 AM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Thursday, August 21, 2014 8:00 PM
Points: 20, Visits: 466
Try this:

When setup your datasource, on the Share Data Source dialog box menu, in Credentials tab, choose "No credentials".

Hope this helps.

Qiang
Post #523446
Posted Wednesday, June 25, 2008 8:30 PM


SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, September 4, 2009 1:18 AM
Points: 34, Visits: 158
Hi,

Sorry but It's my first time to deploy a report in BIDS and I dunno where to find the what you've said "setup datasource". Can you please tell me where to find that?:D
And also I'm wondering, does IIS have something to with authentication of the windows...or somethig to do with BIDS when deploying a report?

Thanks...:)
Post #523819
Posted Wednesday, June 25, 2008 10:11 PM


SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, September 4, 2009 1:18 AM
Points: 34, Visits: 158
Hi Qiang,

I have figure out where that datasource is, I choose the "No Credential" radio button and try again to deploy my report but no luck it is still prompting waiting for Username and Password to be type in textbox. And back in credentials tab I choose the radio button Use a specific User name and password, Deploy my report and type there what I have been set in Credentials but unfortunately it didn't work.
Post #523841
Posted Thursday, June 26, 2008 9:09 PM


SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, September 4, 2009 1:18 AM
Points: 34, Visits: 158
Hi,

I have conclude that IIS is got something to do with deploying a project because when I choose Integrated Windows authentication and Anonymous Access and browse the default Web site I can browse the http://localhost/iishelp/iis/misc/default.asp and at the same time deploying the report through BIDS. It gives an error "A connection could not be made to the report server http://localhost/reportserver".
But when I unchecked Integrated Windows authentication and just leave the Anonymous Access and tried again to deploy the report, it now works, though the annoying Reporting Services Login box prompt again expecting the user to give the Username and Password.
I am all new to this... So could someone please help me?
Post #524720
Posted Sunday, June 29, 2008 9:36 PM
SSC Eights!

SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!

Group: General Forum Members
Last Login: 2 days ago @ 5:51 PM
Points: 843, Visits: 2,486
try this

Open the report inside Visual Studio

On the Data tab click on the three dots next to the "Dataset" dropdown list. This will open the Dataset dialog box.

Click the button with the three dots next to the "Data Source" dropdown list. This will display the Data Source dialog box.

Click on the "Credentials" tab and select either the "Use Windows Authentication" or the "Use a specific name..." radio button. If the latter is slelected, enter a username and a password

I usually use a SQL user (not a windows user) specifically for running reports - but I would expect that using Windows Authentication would be equally successful, and wouldn't prompt for a password...

:)
Post #525726
Posted Monday, June 30, 2008 12:07 AM


SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, September 4, 2009 1:18 AM
Points: 34, Visits: 158
Hi Ivannah,

I've already done that, from this post..

" I have figure out where that datasource is, I choose the "No Credential" radio button and try again to deploy my report but no luck it is still prompting waiting for Username and Password to be type in textbox. And back in credentials tab I choose the radio button Use a specific User name and password, Deploy my report and type there what I have been set in Credentials but unfortunately it didn't work. "

don't know what to do.....

Thanks for your response...:)
Post #525740
Posted Monday, June 30, 2008 3:23 PM
SSC Eights!

SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!

Group: General Forum Members
Last Login: 2 days ago @ 5:51 PM
Points: 843, Visits: 2,486
when you deploy your report do you also deploy the datasource?

In Visual Studio, if you right click on the project and select 'properties', then click on 'configuration properties | general' is the 'overwritedatasource' value (under 'deployment') set to 'true'?

If not, then any changes you make to the credentials will not be deployed. I'm no expert, but have had issues with datasources in the past.

Another thing to check is: on the properties of the datasource, general tab, click the 'edit' button adjacent to the connection string and then click the test connection button. If you are using a 'specific user name and password' these should be displayed, and if correct you should be able to connect from VS at least - then check the deploy settings as per above
Post #526255
Posted Monday, June 30, 2008 11:27 PM


SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, September 4, 2009 1:18 AM
Points: 34, Visits: 158
Hi Ivanna,

I set the OverwriteDataSources to = 'true'. And I also used SQL server account and set a Username (computername\user) and Password. And deploy the report, when the Reporting Services Login box prompts I typed the Username and password that I set a while ago.But It doesnt accept it. Also when I tried to 'run' the report, you have to type the username and password before viewing the report and again it doesn't accept the username and password.
Thanks....:)
Post #526325
Posted Tuesday, July 1, 2008 3:03 PM
SSC Eights!

SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!

Group: General Forum Members
Last Login: 2 days ago @ 5:51 PM
Points: 843, Visits: 2,486
have you checked the properties of the data source once its been deployed to the report server? For comparison, on the report server, I have the following set up for a typical datasource:

- "Name" : name of datasource
- "enable this data source": is checked
- "connection type": MS SQL Server
- "connection string": Data Source= name of SQL server
Catalog = name of database
- "Credentials stored securely in the report server" (radio button):
User name = SQL Username or 'sa'
Password = password for the above

everything else is blank / not filled in / not checked

I don't use windows authentication when setting up the data source, I usually create a SQL Login/user with db_datareader permission on the database. This user is created specifically for running reports on the database. Alternatively, try using 'sa'

Hope this helps - not sure what else to suggest - maybe someone with more experience will have some advice on what else to check
:)
Post #526912
« Prev Topic | Next Topic »

Add to briefcase 12345»»»

Permissions Expand / Collapse