Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

SQL SERVER 2005 Collation Expand / Collapse
Author
Message
Posted Monday, May 19, 2008 3:04 PM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Wednesday, October 08, 2008 9:41 PM
Points: 29, Visits: 113
Friends,
I have a Database on a Development Server with collation Settings
"SQL_Latin1_General_CP1_CI_AS" . Now i moved this Database to Newly installed Test Server. But Collation of the Test Server is "Latin1_General_CI_AI".
I am trying to execute the Stored Procedures with input parameters.
This is giving the following Error
"Cannot resolve the collation conflict between "SQL_Latin1_General_CP1_CI_AS" and "Latin1_General_CI_AI" in the equal to operation. "

So, as the collation is different ,i tried to change the collation of System Databases ( Master, Model. Temp, MSDB) to
"SQL_Latin1_General_CP1_CI_AS".
It is not allowing to Alter that Collation changes.
Can anybody tell whether it is possible to change system Databases Collation or any other method to fix this problem.




Post #503165
Posted Monday, May 19, 2008 11:16 PM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Wednesday, January 23, 2013 9:22 AM
Points: 1,062, Visits: 355
I think you might have to re-install it with the old collation name. I am not sure if you could just run the install and made the collation selection change. I am sure you could uninstall and then re-install since it is a new box with nothing on it.


Sopheap



Post #503294
Posted Tuesday, May 20, 2008 1:32 AM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Wednesday, March 19, 2014 1:27 AM
Points: 2,366, Visits: 1,837
Hi

If you do not want to reinstall then you can change the collation of the database. Whenever you create a new db you will have the server collation as the default and you will have to change it.



"Keep Trying"
Post #503349
Posted Tuesday, May 20, 2008 1:48 AM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Saturday, March 21, 2009 12:49 PM
Points: 50, Visits: 64
I had the same problem, I couldn't change the collation and I've learned to do

select * from tableA join tableB on tableA.fieldA collate [....] = tableB.fieldB

or


select * from tableA where fieldA in (Select fieldB collate [....] from tableB)

I hope this helps!
Post #503357
Posted Tuesday, May 20, 2008 1:49 AM
SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: Friday, October 26, 2012 2:14 PM
Points: 402, Visits: 598
You can rebuild system databases in Sql 2005 and specify the collation as well using the below command,

start /wait CD or DVD Drive\setup.exe /qn INSTANCENAME=MSSQLSERVER REINSTALL=SQL_Engine REBUILDDATABASE=1 SAPWD=NewStrongPassword SQLCOLLATION=NewSystemCollation

But before proceeding with that you need to script all the logins, jobs, take a backup of all your dts packages and to be on the safer side take a full backup of all the user databases as well. After rebuilding check the collation of the system databases and see if they are as desired. Then run the scripts to recreate all the logins, jobs etc..


- Deepak
Post #503358
Posted Tuesday, May 20, 2008 2:34 AM
SSC Eights!

SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!

Group: General Forum Members
Last Login: Thursday, March 27, 2014 2:29 PM
Points: 990, Visits: 13,439
just for info those 2 collations are kinda the same settings, however you get one when the default language of the machine is set to US and the other when its correctly (assuming your in the UK) been set to UK.
Post #503374
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse