Click here to monitor SSC
SQLServerCentral is supported by Redgate
Log in  ::  Register  ::  Not logged in
Home       Members    Calendar    Who's On

Add to briefcase

Thai Buddhist Calendar format in SQL Server Expand / Collapse
Posted Thursday, April 17, 2008 3:30 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, April 17, 2008 6:29 AM
Points: 5, Visits: 6
People in Thailand use the Thai Buddha calendar format, which is 543 years ahead of the Gregorian calendar format. The year in the Thai Buddha calendar now is 2551. This, though handled in the operating system (Windows 2003), is not handled in SQL Server 2005.

I have tried searching settings in SQL Server, but have not been able to find anything. Is there a setting where I can set the calendar/date formats at the server/database level?

Steps to reproduce the problem:

1. Change Windows regional settings to Thai.
2. Add the Thai language in the Windows regional settings.
3. Set THAI_CS_AS as the default collation during SQL Server installation.
4. Set THAI_CS_AS as the collation for the database I'm testing this on.
5. Set the default language to Thai (sp_configure 'default_language', 32)
6. Run the following commands:

set language Thai
set dateformat 'dmy'

SET @Today = '12/1/2008'
SELECT DATENAME(month, @Today) AS 'Month'

The output I get is this (and this is the expected output): มกราคม

However, when I try running the same query to get the date:

SET @Today = '12/1/2008'
SELECT DATENAME(year, @Today) AS 'Year'

I get '2003' as the output. It should be displaying 2551.

I would like to know if there is a setting where I can set the calendar format from Gregorian to Thai Buddhist at the database/server level.

SOS !!!
Post #486237
Posted Thursday, April 17, 2008 4:08 AM



Group: General Forum Members
Last Login: Tuesday, May 29, 2012 11:22 AM
Points: 1,755, Visits: 4,652
Duplicate post.

Ryan Randall

Solutions are easy. Understanding the problem, now, that's the hard part.
Post #486256
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse