Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Legacy DTS - Migration Issue Expand / Collapse
Author
Message
Posted Monday, March 10, 2008 8:18 AM
SSC Journeyman

SSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC Journeyman

Group: General Forum Members
Last Login: Wednesday, October 3, 2012 6:35 AM
Points: 97, Visits: 501
Not sure if anyone has seen this issue before, but i have been migrating a lot of DTS packages from 2000 to 2005. The majority have gone across with no problems are running like a dream through scheduled jobs...

...however i have hit a bizzare problem with one that imports data into our mainframe. Its quite a simple DTS - with a straight forward transformation from a table to a text file destination.

The text file destination is setup as 'fixed width' with ANSI and default row delimiters. No field or text delimiters as they are greyed out when you select 'fixed width'. When i run the export step from within the legacy dts section the text file looks how it should, when i migrate it over to 2005 and then run it, the last column in the textfile (nvarchar(4)) has " " wrapped around it. for instance "DESK" or "FIELD" where it should be DESK or FIELD. Mainframe JCL programme doesn't accept this and rejects the dataset, would prefer to sort the DTS than the programme!

Has anyone come across this before? or is it just another bug i need to log...??


Oraculum
Post #466692
Posted Tuesday, March 11, 2008 10:30 AM
Hall of Fame

Hall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of Fame

Group: General Forum Members
Last Login: Tuesday, July 8, 2014 12:24 PM
Points: 3,475, Visits: 579
Hi,

If you say, this is a simple job to output content of one table to a flat file, just re-create this package in 2005. Right-click on the database, select Tasks ->Export Data and follow the wizard. Specify your source server and authentication, specify the destination as a Flat File Destination, give it a name, specify ANSI code page, delimited format and on the same screen specify the text qualifier. When I tried it, it was a word none with the less sign before it and the more sign after it. After that specify the table or query, and complete other screens of the wizard.
Here is the output I got when I tried to output roleid and rolename from Roles table of ReportServer database:
{3CF68CDB-D16C-47F0-9463-DD45F0E328ED} Report Builder
The string Report Builder does not contain quotes around them.

The other strange thing happened when I posted this post initially and had the word none with these less and more signs around it mentioned twice. Guess what: everything between these None words disappeared from my post, it probably interpreted it as some html tag

Yelena



Regards,
Yelena Varshal

Post #467579
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse