Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase 12»»

The OLE DB provider "Microsoft.Jet.OLEDB.4.0" has not been registered. Expand / Collapse
Author
Message
Posted Sunday, January 20, 2008 4:12 AM
SSC Journeyman

SSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC Journeyman

Group: General Forum Members
Last Login: Sunday, April 26, 2009 7:37 AM
Points: 87, Visits: 307
Can someone please help me.

I executed these Commands

EXEC sp_configure 'show advanced options', 1;
GO
RECONFIGURE;
GO
EXEC sp_configure 'Ad Hoc Distributed Queries', 1;
GO
RECONFIGURE;
GO

--- Error message
Configuration option 'show advanced options' changed from 1 to 1. Run the RECONFIGURE statement to install.
Configuration option 'Ad Hoc Distributed Queries' changed from 1 to 1. Run the RECONFIGURE statement to install.



---I then executed this query

--Insert Data into an EXCEL spreadsheet
INSERT INTO OPENROWSET ('Microsoft.Jet.OLEDB.4.0', 'Excel 8.0;Database = D:\CreditCard\CampaignData.xls;',
'SELECT * FROM [Sheet1$]')

SELECT

Campaign,
ContactNumber,
[Name],
IDNumber,
NewRepeatCat,
OriginalLoanOfficer,
CreationDate,
OrganogramDescription,
ClientNumber,
LoanID,
AccountNumber,
CardNumber,
FinalLoanOfficer,
FinalBranch,
Status,
CardStatus,
StraightLimit
Capital,
StartDate
FROM #CC1
ORDER BY CreationDate


I I got the error message below. How do I fix this? Is it also possible to delete data in the spreadsheet before
inserting.

Msg 7403, Level 16, State 1, Line 1

The OLE DB provider "Microsoft.Jet.OLEDB.4.0" has not been registered.






Post #445277
Posted Sunday, January 20, 2008 8:05 PM
UDP Broadcaster

UDP BroadcasterUDP BroadcasterUDP BroadcasterUDP BroadcasterUDP BroadcasterUDP BroadcasterUDP BroadcasterUDP Broadcaster

Group: General Forum Members
Last Login: Friday, April 5, 2013 4:43 PM
Points: 1,473, Visits: 1,314
I may need to run sp_addlinkedserver before uring your query command.
Post #445325
Posted Monday, January 21, 2008 2:56 AM


Mr or Mrs. 500

Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500

Group: General Forum Members
Last Login: Tuesday, March 11, 2014 3:34 AM
Points: 549, Visits: 1,554
May be the requested OLE DB provider is not installed in your system. Run component checker ( MDAC) and download the required version from the site. Call up MS Support for the above they will check and download it for you. It may be a free service to guide you to get the correct version of Mdac.

"More Green More Oxygen !! Plant a tree today"
Post #445380
Posted Tuesday, January 22, 2008 10:08 AM
Mr or Mrs. 500

Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500

Group: General Forum Members
Last Login: Thursday, February 26, 2009 3:02 PM
Points: 515, Visits: 655
raym,


I second the recommendation to verify your MDAC components.

Troubleshooting Guide:

Component Checker: Diagnose problems and reconfigure MDAC installations
http://support.microsoft.com/kb/307255/


You can download the MDAC Component Checker software tool here:

MDAC Utility: Component Checker
http://www.microsoft.com/downloads/details.aspx?FamilyId=8F0A8DF6-4A21-4B43-BF53-14332EF092C9&displaylang=en

The most recent MDAC version(s) can be found at:

Microsoft Data Access Components (MDAC) 2.8
http://www.microsoft.com/downloads/details.aspx?FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c&displaylang=en

and

Microsoft Data Access Components (MDAC) 2.8 SP1
http://www.microsoft.com/downloads/details.aspx?familyid=78cac895-efc2-4f8e-a9e0-3a1afbd5922e&displaylang=en


Hope This Helps


"Key"
MCITP: DBA, MCSE, MCTS: SQL 2005, OCP
Post #445976
Posted Thursday, January 24, 2008 10:45 AM
Old Hand

Old HandOld HandOld HandOld HandOld HandOld HandOld HandOld Hand

Group: General Forum Members
Last Login: Wednesday, August 6, 2014 8:05 AM
Points: 331, Visits: 550
Actually, you may want to try creating a linked server and see if you get the same error. I scripted a linked server and got the message "The OLE DB provider "MSDAORA" has not been registered." only because the linked server had a missing or wrong configuration. So you might want to do a little testing first. I always found it easier to use a linked server instead of OPENROWSET--but that's just me


Post #447089
Posted Sunday, February 22, 2009 8:58 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Friday, July 11, 2014 6:06 PM
Points: 7, Visits: 215
If you are running 64 bit SQL Server 2005 it may not be possible.
I found the the MDAC linked server for Excel only works in 32 bit.
I use SSIS to import Excel Data into 64 bit SQL 2005.
Post #662342
Posted Friday, March 20, 2009 11:35 AM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Tuesday, August 19, 2014 12:28 PM
Points: 56, Visits: 568
has anyone have success with the latest 64-bit OleDB driver. I have installed the 64-bit Oledb driver but still not able to import Excel data into a sql db.


Post #680608
Posted Wednesday, December 30, 2009 2:03 PM
SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Saturday, June 28, 2014 8:50 AM
Points: 2,649, Visits: 766
I did not mess with the 64 bit MDAC... the version on server 2008 was higher than the listed MDAC patch so I believe the problem lay elsewhere.

I checked a couple of other items. First, that it was possible that the registration needed a kick start so I simply added a dummy Access database to the linked servers and seeing it was there in full, I found another issue that resolved my problem.

In the project file, Configuration Properties, Debugging, there is an option to set 64 bit debugging to true or false. Once it was set to false, I stopped receiving the error. I'm not sure the answer was just the one step, so I include the other step (Jump Start above) as a reference.


Jamie
Post #840578
Posted Saturday, February 20, 2010 9:49 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Saturday, February 20, 2010 9:40 PM
Points: 1, Visits: 0
Please explain in more detail about the fix you found "In the project file, Configuration Properties, Debugging, there is an option to set 64 bit debugging to true or false."

I am also receiving the error "The 'Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine." when trying to run custom software on my machine. System is Windows Vista Home Premium Service Pack 2 64-bit Operating System.

I dropped msjetoledb40.dll directly into the System 32 folder but that did not work.
Post #869750
Posted Sunday, February 21, 2010 7:04 AM
SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Saturday, June 28, 2014 8:50 AM
Points: 2,649, Visits: 766
In the project file, Configuration Properties, Debugging, there is an option to set 64 bit debugging to true or false. Once it was set to false, I stopped receiving the error.


If the question was directed elsewhere, my apologies - otherwise, this is all I have.


Jamie
Post #869837
« Prev Topic | Next Topic »

Add to briefcase 12»»

Permissions Expand / Collapse