Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

xp_cmdshell Enable Expand / Collapse
Author
Message
Posted Thursday, November 15, 2007 4:40 AM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Tuesday, December 8, 2009 10:24 AM
Points: 63, Visits: 61
Hi,
Could you please help me out this issue

I am facing an issue with xp_cmdshell

folowing are error message,how do i enable xp_cmdshell

"The xp_cmdshell proxy account information cannot be retrieved or is invalid. Verify that the '##xp_cmdshell_proxy_account##' credential exists and contains valid information. "
Post #422547
Posted Thursday, November 15, 2007 4:45 AM
Old Hand

Old HandOld HandOld HandOld HandOld HandOld HandOld HandOld Hand

Group: General Forum Members
Last Login: Friday, July 31, 2015 1:00 AM
Points: 344, Visits: 349
What is the account by which you have logged in?

Most likely you account is not a member of sysadmin role, then the SQL Server 2005 will use the proxy account to run the OS command which command called by xp_cmdshell. You omer must to create a credential first and mapping a window account using this command:
EXEC sp_xp_cmdshell_proxy_account ‘proxy account’ ,’password’
Post #422550
Posted Thursday, November 15, 2007 4:52 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: 2 days ago @ 7:18 AM
Points: 6,336, Visits: 7,325
And to enable xp_cmdshell (if you haven't already), go to SQL Server Surface Area Configuration -> Features. This is where you can enable it. It'll be listed under the Database Engine as xp_cmdshell. There's a check box that you need to click on and that's all you need to get started.

Just remember that xp_cmdshell is disabled by default because of security issues. And just because you enable it doesn't mean you've got the proxy account stuff working.


Brandie Tarvin, MCITP Database Administrator

LiveJournal Blog: http://brandietarvin.livejournal.com/
On LinkedIn!, Google+, and Twitter.

Freelance Writer: Shadowrun
Latchkeys: Nevermore, Latchkeys: The Bootleg War, and Latchkeys: Roscoes in the Night are now available on Nook and Kindle.
Post #422552
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse