Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

SQL Server Agent stops and cannot start Expand / Collapse
Author
Message
Posted Monday, October 8, 2007 3:53 AM
Old Hand

Old HandOld HandOld HandOld HandOld HandOld HandOld HandOld Hand

Group: General Forum Members
Last Login: Thursday, March 6, 2014 2:38 AM
Points: 398, Visits: 2,423
My SQL Server Agent stops and cannot be started when viewing the error logs it displays the following errors:

[298] SQLServer Error: 18456, Login failed for user 'NT AUTHORITY\SYSTEM'. [SQLSTATE 28000]

000] Unable to connect to server '(local)'; SQLServerAgent cannot start

[098] SQLServerAgent terminated (normally)

tried starting using the Services in control panel but to no avail what could be the problem? dunno what errors are saying....

There are no errors written in the event viewer only in the SQL Server Agent Error Log although this happened in my dummy database (testing server) i want to know what happened in my SQL Server agent



"-=Still Learning=-"

Lester Policarpio

Post #407905
Posted Monday, October 8, 2007 4:56 AM
SSCarpal Tunnel

SSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal TunnelSSCarpal Tunnel

Group: General Forum Members
Last Login: Today @ 7:14 AM
Points: 4,432, Visits: 4,168
Looking at the error message my first guess would be that you removed the Builtin\Administrators and now the local system acocunt can't login to the server.
If that's the case add a windows login 'NT Authority\System' and make it member of tyhe sysadmin role.

Hope this helps
Markus


Markus Bohse
Post #407916
Posted Monday, October 8, 2007 6:56 PM
Old Hand

Old HandOld HandOld HandOld HandOld HandOld HandOld HandOld Hand

Group: General Forum Members
Last Login: Thursday, March 6, 2014 2:38 AM
Points: 398, Visits: 2,423
thanks very much Marcus!!!!!! works very fine the SQL Server Agent starts again ill take note this information

"-=Still Learning=-"

Lester Policarpio

Post #408246
Posted Friday, February 6, 2009 1:17 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Friday, January 13, 2012 9:37 AM
Points: 3, Visits: 10
Hola, Yo tenía el mismo problema y también me funcionó. Gracias.
Post #651950
Posted Tuesday, October 18, 2011 1:26 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Wednesday, October 19, 2011 11:28 AM
Points: 1, Visits: 19
You may solve this problem by assigning user rights to the user: "NT AUTHORITY\SYSTEM".
Follow these steps:
Open "SQL Server Management Studio".
Open "Security, and then Logins".
Rightclick on user: "NT AUTHORITY\SYSTEM >> Properties".
Select "Server Roles" tab, and check the "sysadmin" server role.
You are done. SQL Server Agent will be started now.
Post #1192447
Posted Monday, August 19, 2013 1:27 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Wednesday, August 28, 2013 9:28 AM
Points: 5, Visits: 9
Unable to Start SQL Server Agent: it's greyed out and there are no options for it.

Running Windows-7 Pro 32 bit, with SQL Server 2008 R2. Apparently unable to install Management Studio or maybe it's already installed.

Cannot create a user=> "NT Authority/System" as those characters are not allowed in the username. The is only 1 user acount => john with Admin privildges. How do I create this NT Authority account and configure it?

Thanks
Post #1485972
Posted Saturday, May 31, 2014 3:33 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Friday, June 20, 2014 2:49 PM
Points: 10, Visits: 455
Try these 2 way and share if it works...

1st way

USE master

CREATE LOGIN [NT AUTHORITY\SYSTEM] From Windows with default_database = [master], DEFAULT_LANGUAGE=[us_english]

2nd way

If this account is missing under Security/Logins then please add the login by the following syntax:

sp_grantlogin 'NT AUTHORITY\SYSTEM' if this fails then try this sp_grantlogin '[NT AUTHORITY\SYSTEM]'

then

make sure the default database for ' NT AUTHORITY\SYSTEM ' login is master.

then

Go to 'Security->Logins' in Management Studio, open the properties window of ' NT AUTHORITY\SYSTEM ' login, at the 'User Mapping' tab, map the appropriate database and select the required database role for each database.

Sanjiv
HTH
Post #1576388
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse