Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase ««12

Sql Server Management Studio : How to Logon with different windows username??? Expand / Collapse
Author
Message
Posted Wednesday, September 12, 2007 6:21 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Sunday, September 16, 2012 11:35 PM
Points: 48, Visits: 161
Ahh... now you mention it, I'm not sure I have actually tried this with sql2005/SSMS. At my last job I used this method... but it was sql2k.

So sorry Ian, you might be out of luck.
Post #398462
Posted Wednesday, September 12, 2007 9:41 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Thursday, August 16, 2012 7:39 AM
Points: 46, Visits: 142

I connect cross domain with SSMS -- but I have to set up an alias in my SQL Server client configuration.
You can try this:

Follow John's steps to issue the net use command.

Open SQL Server Client Network Utility (start-> run->enter "cliconfg")
1. enable Named Pipes protocol (and move to top in the order)
2. under the Alias tab, add a new alias with:
  a. "Named Pipes" selected under Network Libraries
  b. enter [servername], for servername (you should see something like "\\[servername]\pipe\sql\query" in the pipe field)

What I haven't figured out is if the order (net use vs. cliconfg) matters. sometimes i've had to delete the connection and the alias and start all over before
I get a good connection).

good luck,

 

Post #398581
Posted Friday, September 13, 2013 11:59 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, October 24, 2013 4:55 PM
Points: 1, Visits: 12
The following also works, although you must manually enter the password:

runas /netonly /user:remotedomain.com\username "Ssms.exe -S sqlserver.remotedomain.com -E -nosplash"
Post #1494690
« Prev Topic | Next Topic »

Add to briefcase ««12

Permissions Expand / Collapse