Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase ««12

The process could not execute ''sp_replcmds'' on PRODUCTION Expand / Collapse
Author
Message
Posted Thursday, February 25, 2010 3:21 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, February 25, 2010 3:11 PM
Points: 1, Visits: 0
Sorry to add to an old post but hopefully it helps.

I had the same problem today after REORGANIZING a ton of heavily fragmented indexes (rebuild not an option).

To fix I had to go into Enterprise Mgr..... find the agent under replication->log reader agent
Right click, choose agent profiles.

This allowed me to create a new profile with a larger timeout value and i had to also set ReadBatchSize to 1

After doing this replication is now running again, it just took longer than normal to catch back up but this has fixed the problem for me. I will change the ReadBatchSize parameter back to 500 after a few hours but thought I'd share my experience with this issue.

Thanks.
Post #873052
Posted Wednesday, March 3, 2010 5:41 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Wednesday, June 20, 2012 3:52 AM
Points: 3, Visits: 42
Thank you. Your answer just saved me three hours. It worked!

Regards
Nneka
Post #875863
Posted Monday, August 2, 2010 8:08 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Monday, January 14, 2013 10:19 AM
Points: 4, Visits: 15
Sorry this is such a late post but we just started having this same issue on Sundays when our REORG's run. Any ideas on why reorganizing causes this to happen? I will try your fix next time unless I can find what is causing this to happen and can prevent it.
Post #962216
Posted Monday, June 3, 2013 3:12 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: 2 days ago @ 1:38 AM
Points: 8, Visits: 145
HI, I'd thought that I'd add my experience on this. We experienced the same issue with the log reader agent in Sql 2000, caused by a now outage over the weekend. Instead of amending the -readbatchsize to 1, I amend from 500 to 100, which also worked. I suppose it depends on the severity of the backlog. So you don't need to reduce all the way down to single batch sizes.
Post #1459128
« Prev Topic | Next Topic »

Add to briefcase ««12

Permissions Expand / Collapse