Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

"Last Database Backup" info not sync'ed across AlwaysOn AG - monitoring issue Expand / Collapse
Author
Message
Posted Thursday, August 14, 2014 7:36 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Thursday, October 30, 2014 2:07 AM
Points: 26, Visits: 205
I haven't been able to find any info on google/other places on this issue - so i'm hoping some of you guys have some info or ideas.
I realize it might be some setting in the SCOM management pack, but would appreciate if someone can point me at the right article/setting so i can talk to the SCOM admin about it.

The issue is that i'm running a couple SQL 2014 AlwaysOn Availability groups, and using Ola Hallengrens scripts to do the backup.
Backup preference is set to "prefer secondary"

What happens is that full backups are taken on the primary (active) node, while transaction backups are offloaded to the passive node.
The result of this is that i will have a consistent backup set, but will get alerts (from SCOM) that databases are not being backed up.

For instance one database will have info like this:
Primary node (at the moment):
Last Database Backup : 09-08-2014 05:00:15
Last Database Log Backup : 06-08-2014 08:16:59

Secondary node (at the moment):
Last Database Backup : 06-08-2014 08:16:58
Last Database Log Backup : 14-08-2014 14:55:01

(the 6th of august was when i added this DB to the AG)

So even if the backup is running as expect - then for the secondary server SCOM will raise an alert that I haven't done a full backup within the last 8 days (as we usually do full backups weekly)

Any ideas on how to work around this issue or how/where in the SCOM MP this behaviour can be tweaked?

Br, Henrik
Post #1603258
Posted Saturday, August 16, 2014 4:00 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Friday, October 31, 2014 10:00 PM
Points: 170, Visits: 1,880
If you would like the full backups to be performed on the secondary server as well, you can add the option @CopyOnly = 'Y' to the full backup jobs.

(I don't have knowledge about the SCOM monitoring.)

Ola Hallengren
http://ola.hallengren.com
Post #1604022
Posted Saturday, August 16, 2014 1:28 PM


SSC-Forever

SSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-Forever

Group: General Forum Members
Last Login: Today @ 2:50 AM
Points: 40,658, Visits: 37,118
AFAIK, the last backup date comes from MSDB and the data in MSDB is not synced across an AG.

You can sync the data yourself, the backup history tables in MSDB aren't system tables, but this may not be a great idea, get it wrong and you could mess up many of the tools. Otherwise ask the SCOM guys if they can disable that alert for the secondary servers.



Gail Shaw
Microsoft Certified Master: SQL Server 2008, MVP
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

We walk in the dark places no others will enter
We stand on the bridge and no one may pass

Post #1604128
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse