Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Fields not appearing in Report Data tab Expand / Collapse
Author
Message
Posted Thursday, May 29, 2014 7:21 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, August 15, 2014 5:11 AM
Points: 43, Visits: 235
I'm fairly certain that this is an environment issue but I don't know where to look...

The problem is I have a specific stored procedure that I am calling from SSRS 2008R2. It is nothing out of the ordinary, just over 1000 lines and for a given parameter it returns 33 records of 43 fields.

I have reduced the problem to its component parts by creating a new report, creating a new dataset to run the SP, I add the solitary parameter to be passed and click 'Refresh Fields'. Nothing happens.

When I click the 'Query Designer' button and execute the query I am asked for the value of the parameter and it returns the data correctly.

How can I get the field list to appear in the Report Data tab?

(I should add that other sps work just fine!)
Post #1575566
Posted Thursday, May 29, 2014 9:25 AM


SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Today @ 12:00 AM
Points: 1,780, Visits: 5,749
Does this SP have SET NOCOUNT ON; at the start? If not, try adding it.

does the SP use temporary tables? If yes, try adding a dummy 0 row select to the start that returns the exact same structure as your final select.


MM


  • MMGrid Addin
  • MMNose Addin


  • Forum Etiquette: How to post Reporting Services problems
  • Forum Etiquette: How to post data/code on a forum to get the best help - by Jeff Moden
  • How to Post Performance Problems - by Gail Shaw

  • Post #1575637
    Posted Friday, July 25, 2014 6:45 PM


    Old Hand

    Old HandOld HandOld HandOld HandOld HandOld HandOld HandOld Hand

    Group: General Forum Members
    Last Login: Wednesday, September 24, 2014 4:50 PM
    Points: 358, Visits: 876
    I know this is not a current post but one thing to check is that in your desing environment you are pointing to the same data source as in the "published to" environment. Just one of those things in front of your nose you want to check off.
    Post #1596442
    « Prev Topic | Next Topic »

    Add to briefcase

    Permissions Expand / Collapse