Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Xp_cmdshell Error Expand / Collapse
Author
Message
Posted Wednesday, March 5, 2014 12:33 PM
Say Hey Kid

Say Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey Kid

Group: General Forum Members
Last Login: Friday, August 1, 2014 10:55 AM
Points: 701, Visits: 1,732
Hi,

I have an old SQL 2000 server that uses xp_cmdshell. Been working fine for years.

Now it comes up with an error when I run this:

exec master.dbo.xp_cmdshell 'dtsrun -E -Swsisql3 -NImport_APDIST'

I get this error:

Cannot load the DLL ppspps, or one of the DLLs it references. Reason: 126(The specified module could not be found.).

So in troubleshooting I run this:

use master 
go
sp_helpextendedproc 'xp_cmdshell'

the results:

name dll
---------------------------
xp_cmdshell ppspps

I can't seem to figure out why the DLL is missing? I searched for ppspps.dll and is not on the server. Is this even the correct file?





Post #1547979
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse