Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Distributor does his work but its always stopping Expand / Collapse
Author
Message
Posted Monday, January 27, 2014 4:01 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, March 28, 2014 10:39 AM
Points: 36, Visits: 257
Hi guys,

I have a transactional replication between two servers running with SQL Server 2008R2 and the distributor apparently is doing his work perfectly.
What i can't understand is why am i receiving alerts each 20minutes +- with this information

"The SQL Server performance counter 'Running' (instance 'Distribution') of object 'SQLServer:Replication Agents' now equals the threshold of 0.00."
COMMENT: AlertSQLQG001- Replication has an issue. Please check whether the distribution job is running.

JOB RUN: (None)


I already took a look on the Replication Monitor and the Job says "Running"
Has anyone had this problem before? What can i do? I tried to search online for more info about this one, but without success

Thanks
Post #1534924
Posted Tuesday, January 28, 2014 8:13 AM


Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Yesterday @ 8:43 AM
Points: 1,201, Visits: 2,661
When you say it is doing all of its work but always stopping... what do you mean by always stopping?


Post #1535467
Posted Tuesday, January 28, 2014 8:18 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, March 28, 2014 10:39 AM
Points: 36, Visits: 257
Hi there,

Thank you for your reply.
Well .. i don't have any undistributed command , so it seems he is doing his work :)

I have an alert set up to tell me when the threshold of the running parameter is equal 0( that means it stopped) and i'm constantly receiving those alerts.
If I take a look into the Job Activity Monitor i dont have any indication that the job stopped, but i keep receiving the alerts from the server...

Thanks,
Tiago
Post #1535478
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse