Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Shared data source not working in report once report is deployed Expand / Collapse
Author
Message
Posted Monday, October 14, 2013 4:55 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Wednesday, October 16, 2013 8:49 AM
Points: 19, Visits: 118
Hi,

Not so new to ssrs but pretty new to setting up logins on sql server to make the report work. I have a report has a shared datasource which points to a relatively new server. I started out setting up with windows authentication, hoping an admin might have set me up correctly. I am an admin for our sql server instances in AD.
In this case my lack of credentials got me an error:
"Cannot create a connection to data source 'xxxxx' (rsErrorOpeningConnection)
Login failed for 'NT Authority\Anonymous LOGON"
I went back into the data source in the development environment and switch to sql authentication, using my sa account for the server. It works in the preview in BIDS.
What happened when I redeployed the data source is that is not overwritten on the server; I can tell this by going to server and clicking on the data source and looking at the xml; my new credentials are not there. I have no way of deleting the datasource so I'm sort of stuck.

Any help would be appreciate.

Thanks,
Fig000


Post #1504572
Posted Tuesday, October 15, 2013 4:14 AM
SSC Veteran

SSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC Veteran

Group: General Forum Members
Last Login: Thursday, October 16, 2014 5:11 AM
Points: 243, Visits: 2,717
How are you deploying your report? If you are deploying from BIDS, one of the options under project properties is to overwrite the datasource. You would want to change that property to true.
Post #1504667
Posted Tuesday, October 15, 2013 3:19 PM
Mr or Mrs. 500

Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500

Group: General Forum Members
Last Login: Tuesday, October 14, 2014 1:48 PM
Points: 593, Visits: 2,109
if you right click on the project name and go to properties there's an option to "overwrite Datasource", that should let you fix the datasource.

Your other error sounds like it could be a kerberos problem. Have you set any SPNs?.
Post #1504996
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse