Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

AMD processor issue Expand / Collapse
Author
Message
Posted Thursday, October 3, 2013 2:58 PM


Mr or Mrs. 500

Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500

Group: General Forum Members
Last Login: 2 days ago @ 10:10 AM
Points: 526, Visits: 1,163
Hi,

I read somewhere, don't recall if it was here or some other forum or blog, that AMD Opteron processors should have hyper-threading disabled in order for SQL Server 2008 R2 use it's "full power", since hyper-threading could "mistake" the engine...
Is it true or has the problem been fixed? The R2 version is RTM and the CPU is Opteron 2435.

Thanks,
Pedro




If you need to work better, try working less...
Post #1501354
Posted Friday, October 4, 2013 6:56 AM


Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Thursday, December 18, 2014 8:32 AM
Points: 23, Visits: 221
Are you talking about the Windows Power Plan settings? If so check these out.

http://sqlserverperformance.wordpress.com/2010/09/28/windows-power-plans-and-cpu-performance

http://www.brentozar.com/archive/2010/10/sql-server-on-powersaving-cpus-not-so-fast

http://greg.blogs.sqlsentry.net/2011/01/ensuring-maximum-cpu-performance-via.html









Jason Carter
Tampa, Florida

"Anyone who stops learning is old, whether at twenty or eighty. Anyone who keeps learning stays young. The greatest thing in life is to keep your mind young" - Henry Ford
Post #1501570
Posted Friday, October 4, 2013 7:20 AM


Mr or Mrs. 500

Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500

Group: General Forum Members
Last Login: 2 days ago @ 10:10 AM
Points: 526, Visits: 1,163
Not quite...
From what I recall from the article someone had the CPU HT active on the BIOS and SQL was "fooled" to think it had more cores that actually had, so MAXDOP with 0 (auto) was launching more threads than the CPU actually supported... But this only happened with AMD CPUs...
Don't know if a SP for 2008 R2 already fix the problem or if this is the problem (don't remember well)...

Pedro




If you need to work better, try working less...
Post #1501591
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse