Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

401 Errors on report builder - Standalone - No IIS or Sharepoint Expand / Collapse
Author
Message
Posted Tuesday, September 17, 2013 2:42 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Tuesday, September 17, 2013 5:47 AM
Points: 2, Visits: 2
Hi,

I have been attempting to sort a security issue out on SSRS 2008 - After several days of searching online I have decided to ask here.

NOTE - IIS and Share point are not a part of this as neither is installed.
Windows server 2008 R2
SQL Server 2008 R2
SSRS 2008

Evereything seems to work fine except for report builder - Which gives when I attempt to open it:

PLATFORM VERSION INFO
Windows : 6.1.7601.65536 (Win32NT)
Common Language Runtime : 4.0.30319.1008
System.Deployment.dll : 4.0.30319.1 (RTMRel.030319-0100)
clr.dll : 4.0.30319.1008 (RTMGDR.030319-1000)
dfdll.dll : 4.0.30319.1 (RTMRel.030319-0100)
dfshim.dll : 4.0.31106.0 (Main.031106-0000)

SOURCES
Deployment url : http://pcl-wb-sql3/ReportServer_UHDEV/ReportBuilder/ReportBuilder_3_0_0_0.application

ERROR SUMMARY
Below is a summary of the errors, details of these errors are listed later in the log.
* Activation of http://pcl-wb-sql3/ReportServer_UHDEV/ReportBuilder/ReportBuilder_3_0_0_0.application resulted in exception. Following failure messages were detected:
+ Downloading http://pcl-wb-sql3/ReportServer_UHDEV/ReportBuilder/ReportBuilder_3_0_0_0.application did not succeed.
+ The remote server returned an error: (401) Unauthorized.

COMPONENT STORE TRANSACTION FAILURE SUMMARY
No transaction error was detected.

WARNINGS
There were no warnings during this operation.

OPERATION PROGRESS STATUS
* [17/09/2013 09:35:53] : Activation of http://pcl-wb-sql3/ReportServer_UHDEV/ReportBuilder/ReportBuilder_3_0_0_0.application has started.

ERROR DETAILS
Following errors were detected during this operation.
* [17/09/2013 09:35:55] System.Deployment.Application.DeploymentDownloadException (Unknown subtype)
- Downloading http://pcl-wb-sql3/ReportServer_UHDEV/ReportBuilder/ReportBuilder_3_0_0_0.application did not succeed.
- Source: System.Deployment
- Stack trace:
at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)
at System.Deployment.Application.SystemNetDownloader.DownloadAllFiles()
at System.Deployment.Application.FileDownloader.Download(SubscriptionState subState)
at System.Deployment.Application.DownloadManager.DownloadManifestAsRawFile(Uri& sourceUri, String targetPath, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestDirectBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options)
at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)
--- Inner Exception ---
System.Net.WebException
- The remote server returned an error: (401) Unauthorized.
- Source: System
- Stack trace:
at System.Net.HttpWebRequest.GetResponse()
at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)

COMPONENT STORE TRANSACTION DETAILS
No transaction information is available.


I have used a couple of logins to test this - It works locally on the server via IE but not remotely. I am at a loss as to what to do now to attempt to sort this issue?

Any ideas? NOTE : I have made the suggested regedit chages, rsreportserver.config changes (And reverted..)
Post #1495401
Posted Tuesday, September 17, 2013 5:49 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Tuesday, September 17, 2013 5:47 AM
Points: 2, Visits: 2
Just found some more information.

The reason this is failing is due to the login I am using is not being used to call the report builder application - Its using my laptops login.

This is very odd behaviour.
Post #1495464
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse