Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

database showing restoring does not add back in to always on high availability group Expand / Collapse
Author
Message
Posted Wednesday, July 17, 2013 9:19 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Tuesday, February 11, 2014 10:12 AM
Points: 110, Visits: 501
i got a primary secondary and a Disaster Recovery servers.

I have a database added to the always on high availability,

as we work on failover cluster, i found it as Always On, on all the servers.

I dont know how but found the DB says restoring...

the always on feature is not enabled to that particular DB.

when i try to add the DB to one of the Availability group it says:

" Failed to join the 'DB' to the availability group 'groupname' on the availability replica 'server name'

the remote copy of DB is not recovered far enough to enable database mrroring or to join it to the availability group. you need to apply the missing log records to the remote database by restoring the curent log backups from the primary database (MS SQL Server error:1408) "

i do restored under norecovery from the primary...

now i couldnot find a way to add it back to the Always On...

Can any one find me a way... or am i missing anything over here???


Rookie here
Post #1474681
Posted Wednesday, July 17, 2013 12:30 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Tuesday, February 11, 2014 10:12 AM
Points: 110, Visits: 501
I had removed it from availability group and

i had deleted the databses manually in all the secondary and also in DR (disaster recovery)

and again added it to the availability group and it stil show as restoring...

I will update if i see any changes........


Rookie here
Post #1474760
Posted Thursday, July 18, 2013 6:23 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Tuesday, February 11, 2014 10:12 AM
Points: 110, Visits: 501
Hi guys,

It worked..
please follow this, if you facew such kind of troubles... correct me if i am wrong.

Up on restoring i faced some LSN incompatibility, So i checked the LSN, and only selected the LSN which is latest.

I restored from primary(database) it showed restoring...

and i left as such yesterday..

Up on checking today, they got synchronized and is in Always On group.

It need time to get synchronized....

i need patience


rookie here
Post #1474997
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse