Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Mixed Mode Authentication not consistent between Windows Users using Mgmt Studio Expand / Collapse
Author
Message
Posted Friday, July 05, 2013 7:28 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Monday, December 30, 2013 5:15 AM
Points: 35, Visits: 77
Currently experiencing strange issue I have not seen before on a SQL Server 2008 R2 instance running on Windows Server 2008 R2. Access to SQL Server via Mgmt Studio under the 'sa' user does not work regardless of which Windows User is logged in. The only way to access SQL Server via Mgmt Studio is to log into Windows with the administrator user and use Windows Authentication to authenticate against SQL Server.

SQL Server Configuration:
Mixed Mode Authentication
Shared Memory Prorocol Access Only (Other protocols have been tried)
SQL Native Client 10 being used to access Sql Server

All of the above is only experienced when using Management Studio. When accessing via ODBC programmatically, configured SQL Server user works just fine regardless of which Windows user is logged in.
Post #1470730
Posted Friday, July 05, 2013 8:25 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, February 14, 2014 6:31 AM
Points: 25, Visits: 71
What is the returned message when you try to login with 'sa'.
Post #1470759
Posted Friday, July 05, 2013 8:46 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Monday, December 30, 2013 5:15 AM
Points: 35, Visits: 77
The most recent errors I have noted have all been:

A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)

Thanks,
-Leif
Post #1470774
Posted Friday, July 05, 2013 8:56 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, February 14, 2014 6:31 AM
Points: 25, Visits: 71
Can you also confirm that you left the other Client Protocols enabled?
Post #1470779
Posted Friday, July 05, 2013 9:02 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Monday, December 30, 2013 5:15 AM
Points: 35, Visits: 77
All other client protocols are disabled. The only protocol that is enabled is Shared Memory. This is part of our standard configuration for all deployments.
Post #1470784
Posted Friday, July 05, 2013 10:20 AM


SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Today @ 11:34 AM
Points: 1,662, Visits: 5,227
Leifton (7/5/2013)
All other client protocols are disabled. The only protocol that is enabled is Shared Memory. This is part of our standard configuration for all deployments.


Your standard deployment is for local access only????

Anyway, have you checked that the Shared Memory Endpoint has not been changed from it's default of "TSQL Local Machine" ?

Have you tried granting sa access to that endpoint - to see if permissions have been lost?

what does your sys.endpoints data look like?

/*------------------------
select *
from sys.endpoints
------------------------*/
name endpoint_id principal_id protocol protocol_desc type type_desc state state_desc is_admin_endpoint
-------------------------------------------------------------------------------------------------------------------------------- ----------- ------------ -------- ------------------------------------------------------------ ---- ------------------------------------------------------------ ----- ------------------------------------------------------------ -----------------
Dedicated Admin Connection 1 1 2 TCP 2 TSQL 0 STARTED 1
TSQL Local Machine 2 1 4 SHARED_MEMORY 2 TSQL 0 STARTED 0
TSQL Named Pipes 3 1 3 NAMED_PIPES 2 TSQL 0 STARTED 0
TSQL Default TCP 4 1 2 TCP 2 TSQL 0 STARTED 0
TSQL Default VIA 5 1 5 VIA 2 TSQL 0 STARTED 0


MM


  • MMGrid Addin
  • MMNose Addin


  • Forum Etiquette: How to post Reporting Services problems
  • Forum Etiquette: How to post data/code on a forum to get the best help - by Jeff Moden
  • How to Post Performance Problems - by Gail Shaw

  • Post #1470808
    Posted Monday, July 08, 2013 5:32 AM
    SSC Rookie

    SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

    Group: General Forum Members
    Last Login: Monday, December 30, 2013 5:15 AM
    Points: 35, Visits: 77
    mm,

    Yes, it is our standard deployment. Local access is preferred in our case.

    The output on the remote machine experiencing the problem is nearly identical to yours (different column names being the difference). I guess I am not sure how to tell if 'sa' can access a particular endpoint. Related to that is I do not now how to grant 'sa' access to an endpoint if it is determined that 'sa' cannot access it.

    Thank You,
    Leif
    Post #1471122
    « Prev Topic | Next Topic »

    Add to briefcase

    Permissions Expand / Collapse