Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Import CSV File Expand / Collapse
Author
Message
Posted Thursday, June 13, 2013 4:36 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Friday, September 12, 2014 9:08 AM
Points: 100, Visits: 328
Hi,

I have a 4 GB CSV file , which i am unable to import in SQL Server 2008 R2, even I not able to open file also. I tried import export wizard also but when i am importing the file , it displaying the records with double quote("").
For Ex:- "Charles"
"$1.2"
Is there any alternate option to import large file into the SQL SERVER or any third party tool which will import the file without double quote.

Thanks in advance-------
Post #1462972
Posted Thursday, June 13, 2013 5:53 AM


SSChampion

SSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampion

Group: General Forum Members
Last Login: Yesterday @ 8:47 AM
Points: 12,905, Visits: 32,168
arooj300 (6/13/2013)
Hi,

I have a 4 GB CSV file , which i am unable to import in SQL Server 2008 R2, even I not able to open file also. I tried import export wizard also but when i am importing the file , it displaying the records with double quote("").
For Ex:- "Charles"
"$1.2"
Is there any alternate option to import large file into the SQL SERVER or any third party tool which will import the file without double quote.

Thanks in advance-------


the import wizard, bulk insert or sqlcmd.exe/bcp.exe are your best choices, especially for large files.

since you got the import wizard to work, i'd suggest redoing it that way; it sounds like you missed selecting the text qualifier (of dbl quote) , because your data is delimited with it.

change this setting and rerun it again:


Lowell

--There is no spoon, and there's no default ORDER BY in sql server either.
Actually, Common Sense is so rare, it should be considered a Superpower. --my son
Post #1462996
Posted Thursday, June 13, 2013 8:43 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Friday, September 12, 2014 9:08 AM
Points: 100, Visits: 328
Thanks ..........its working fine now........
Post #1463131
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse