Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

The component metadata for the script component could not be upgraded to the newer version of the component Expand / Collapse
Author
Message
Posted Wednesday, June 12, 2013 4:15 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, September 11, 2014 4:11 AM
Points: 2, Visits: 241
Hi ,

I have developed SSIS Package in 2008r2 and when i am trying to run the DTSX package in SQL 2012, am getting error like'The component metadata for the script component could not be upgraded to the newer version of the component'. We have to verify this in two ways,

one is either it may be proplem with ssis version or else .net version mismatch.

i wrote a script component code in .net2.0 version and am trying to run that in .net 4.0 version in SSIS Package.

Could you please help me in this problem.


Thanks & Regards,
Thiru.
Post #1462538
Posted Wednesday, June 12, 2013 6:55 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Tuesday, October 28, 2014 10:01 AM
Points: 7,127, Visits: 12,731
It means your 2008 Package cannot be automatically upgraded to 2012 format on the fly before executing. You'll need to manually upgrade the Package to 2012 format and address any issues during that process and save it in 2012 format. Then you will be able to execute the Package in 2012.

__________________________________________________________________________________________________
There are no special teachers of virtue, because virtue is taught by the whole community. --Plato
Post #1462603
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse