Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

ReportViewer v10 issue with slow paging Expand / Collapse
Author
Message
Posted Friday, May 31, 2013 12:11 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Monday, May 19, 2014 6:22 AM
Points: 19, Visits: 33
We have an ASP project with ReportViewer controls. We recently upgraded the controls from v8 to v10. Everything looks good except ONE report with a lot of data, which now takes about 10 seconds to go from the first to the second page. This does not occur with the same data and same version of the report with the v8 ReportViewer.

Has anyone seen anything like that? Are there any settings that we could play with that might help? I tried turning on caching on the server, but that didn't do anything.
Post #1458829
Posted Wednesday, October 2, 2013 10:51 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Friday, September 5, 2014 12:11 AM
Points: 1, Visits: 4
My site is running .net 3.5. When we had reportviewer 9.0, there was no loading dialog during paging, very smooth.Since upgrading to version 10.0, the loading dialog shows up during paging. The code also hits the Page_load, I suppose because of the async postback.

In a summary , the whole paging experience is much slower and gives the expression of an old postback based architecture, rather than any benefit of AsyncRendering. Have you come up with any solution ? I have to upgrade the reportviewer , as version 9 doesn't print in IE 10.
Post #1500984
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse