Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Disabling Service Broker. Expand / Collapse
Author
Message
Posted Wednesday, May 22, 2013 8:43 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Monday, June 2, 2014 11:14 AM
Points: 103, Visits: 450
I have two service broker applications on one instance of database.
One sends/recieve messages locally and other one sends/recieve messages to remote server.

I wanted to disable the Remote service broker so that sender can no longer send messages to the remote queue
I disabled the Queueue but I still see the Reciever is still getting messages and tables getting updated as a result.

I want to stop the Remote Sender queue and I dont want transmission_queue to pile up.

Post #1455558
Posted Wednesday, May 22, 2013 1:53 PM


SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Thursday, September 11, 2014 7:38 AM
Points: 1,855, Visits: 3,452
If you have disabled the queue on the target, then there is no way messages can be delivered to it. How did you disable it?

The only way to prevent transmission_queue to pile up on the initiator is to stop sending messages to the remote service with the disabled queue.
Post #1455673
Posted Wednesday, May 22, 2013 8:09 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Monday, June 2, 2014 11:14 AM
Points: 103, Visits: 450
Thanks for your reply.

I think my post was bit confusing or I didnt explain it correctly.

I want to Stop sending messages to the local Queue that sends it to the remote service. When I disable the Queue on the remote server (right click disable), the messages dont flow anymore and transmission_queue on the Sender starts accumulating. (understood)

My question is when I disable the SENDER queue (right click disable) and keep the RECIEVE (remote) Queue ON....I see the messages still flowing through the Disabled SENDER queue to the ON Remote Queue and the tables getting updated through activation proc on the Remote Server.

Why is that ? can a DISABLED Sender Queue process OUT bound messages ?

I can always disable Trigger to stop sending messages to the Sender Queue...but I want to understand why Disabling the queue doesnt do that...
Post #1455786
Posted Thursday, May 23, 2013 3:14 AM


SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Thursday, September 11, 2014 7:38 AM
Points: 1,855, Visits: 3,452
The initiator (sender) queue is not involved when you send a message to a target, so disabling it will not prevent sending messages from the initiator to the target. It will only prevent messages sent from the target to be received by the initiator.

If you want to stop sending messages to the remote server, you need to removed the T-SQL code that actually sends them.
Post #1455904
Posted Thursday, May 23, 2013 8:33 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Monday, June 2, 2014 11:14 AM
Points: 103, Visits: 450
ok. Thanks for explaining that.
Post #1456036
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse