Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

SSIS packages Expand / Collapse
Author
Message
Posted Friday, March 22, 2013 6:44 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Wednesday, June 12, 2013 5:14 AM
Points: 3, Visits: 27
Hi
Iam running SSIS packages and scheduled it for 30minutes in sqlagent.Iam running nearly 10packages for every 30minutes.The problem is sqlagent history shwoing us package secceeded,but there at some interval of time
data is not transferred.The source database is cache database from intersystems it is having the data.As well as we set the Logging,there are no errors in the log files.Please advice us what to do..

Regards
Srinivas
Post #1434239
Posted Friday, March 22, 2013 7:19 AM
SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Wednesday, March 26, 2014 10:01 AM
Points: 1,726, Visits: 486
I am assuming the package(s) have enough time to run between each schedule and you have logs showing it has executed when expected each time.


if processing no data should never happen i would modify the package to notify you or log when it runs and there is no data to process.

Also if this is occurring regular maybe running it manually (if this is possible) for a few hours to monitor what happens may help highlight the cause of the issue.
Post #1434254
Posted Tuesday, March 26, 2013 5:52 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Wednesday, June 12, 2013 5:14 AM
Points: 3, Visits: 27
Hi

Sorry for the late reply.I have multiple jobs schedulers which will all the schedulers for every 15minutes,so that data will be transferred from cache database to sql db.The query for returning the data is

select * from applicationstat where "timestamp" > dateadd(minutes, -15 ,getdate()) and "timestamp"< getdate()

So it is going to retrieve last 15minutes data.So all the schedulers are running to retrieve each table from the same cache database.Now the problem is sometimes data is missing even the schedulers are showing success status in schedulers history.So iam checking that source database table is having the data because there is an option in SSIS oledb destination control having preview option,when ever i clicked on it,we can ablse to see the data.Even I set the logging there is no error in log files.Please tell me what i hv to check now.

Regards
Srinivas
Post #1435408
Posted Tuesday, March 26, 2013 5:59 AM
SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Wednesday, March 26, 2014 10:01 AM
Points: 1,726, Visits: 486
hows the source populated. maybe is it being populated when your trying to extract it and its not been posted yet?

Post #1435412
Posted Tuesday, March 26, 2013 6:16 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Wednesday, June 12, 2013 5:14 AM
Points: 3, Visits: 27
There is a datasource to connect source database.And in oledb destination control in SSIS having the option preview,once it is clicked we will get top 200
rows ,will come to know whether data is dumping or not.So when i clicked it is showing the data.But once it scheduled at some interval of time data is not transferring but schedulers showing success status.
Post #1435424
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse