Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Could not connect to the report server http://localhost/reportserver Expand / Collapse
Author
Message
Posted Thursday, March 21, 2013 4:11 PM


SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Friday, July 18, 2014 1:00 PM
Points: 178, Visits: 215
I currently have SQL2k8 R2 Reporting services on client machine (Windows 7). I created and deployed reports on this machine. Everything works perfect. I need to move everything to Server machine (W2k8 R2). I installed SQL2k8 R2 and copied the solution have that I have on client machine.
I can open rdl files on server machine but when I deploy reports I get the below error:
******************
TITLE: Microsoft SQL Server Report Designer
------------------------------
Could not connect to the report server http://localhost/ReportServer. Verify that the TargetServerURL is valid and that you have the correct permissions to connect to the report server.
------------------------------
ADDITIONAL INFORMATION:
Unable to connect to the remote server (System)
*********************

I compared server to client machine and checked all the settings are similar in RS configuration manager. However, After I connect to report server, I get similar error (precisely: 'unable to connect to remote server') when I expand any of nodes (Jobs, Security etc).
Similar error when I open http://localhost/ReportServer in internet explorer.
I tried running RS with domain account, network service account, local system account but of no luck.
What else could I be missing here ?
Post #1434068
Posted Tuesday, March 26, 2013 3:07 AM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Tuesday, July 15, 2014 3:08 AM
Points: 68, Visits: 409
I THINK Problem is because of server name or URL may be wrong
check the project URL and change it to the URL same as in
report configuration manager.
then deploy
Post #1435334
Posted Tuesday, March 26, 2013 4:54 AM


SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, July 16, 2014 5:10 AM
Points: 112, Visits: 1,207
Please check this link : http://www.sqlteam.com/forums/topic.asp?TOPIC_ID=154492

Hope it will solve your issue!!


SQL Database Recovery Expert
Post #1435386
Posted Tuesday, March 26, 2013 10:32 AM


SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Friday, July 18, 2014 1:00 PM
Points: 178, Visits: 215
Well, I got the solution from msdn. On my windows server, I did below steps:
1. In the reporting services configuration manager, click web service url. Removed the SSL certificate to the port 443 by clicking advanced button.
2. open the rsreportserver.config file at C:\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\ (file path may be differ based on SQL Server version). Open with administrator privileges.
3. Update and save SecureConnectionLevel field to 0 (initial value is 2) as below:
<Add Key="SecureConnectionLevel" Value="0"/>

Then I am able to deploy my reports. I now see a different issue in accessing my data sources.
When I open the report in the browser, I dont see data sources listed and when I click report I see below error:
"
An error has occurred during report processing. (rsProcessingAborted)
Cannot create a connection to data source 'abcd'. (rsErrorOpeningConnection)
For more information about this error navigate to the report server on the local server machine, or enable remote errors
"
Post #1435607
Posted Wednesday, March 27, 2013 1:39 AM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Tuesday, July 15, 2014 3:08 AM
Points: 68, Visits: 409
I think you have to change the data base name in data source...
Post #1435788
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse