Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

UseSessionCookies? Expand / Collapse
Author
Message
Posted Wednesday, March 13, 2013 11:45 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, May 30, 2013 11:22 AM
Points: 3, Visits: 25
I have a report on SSRS 2008 R2, 2 server scale-out.

The tablix on the report is driven by a dataset that looks for "id in @parameter"

The parameter is internal, multivalued and is generated from a straight SQL select from a tmp table

This tmp table is populated fron a stored procedure defined in another dataset with the report parameters passed to it to derive the record id's I want to show.

Works like a champ, but:

The first time I run it from the report server, I get all the expected values in the tablix for the parameters chosen. If I close/re-open report and run with let's say a different date period, the report comes back with the previous report's values, even though the underlying tmp SQL table did change/update and other expressions on the report change accordingly.

If I close/reopen Internet Explorer, then re-run the report with the new parameters, I get what is expected.

I have caching on the report disabled, thinking session cookie? Is there a downside to setting UserSessionCookie=FALSE in [dbo].[ConfigurationInfo]? Is this even the issue or is this just "the way things work"?

Thanks
Post #1430548
Posted Thursday, March 21, 2013 8:37 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, May 30, 2013 11:22 AM
Points: 3, Visits: 25
This is an issue I caused myself by using a stored procedure to insert rows into a temp table.

Since there is no way to control in what order report elements, datasets, etc run, sometimes the report grabbed the old data from the tmp table before I had a chance to delete and re-insert.

So re-wrote stored procedure to just return the id list I was looking for, that now populates my internal parameter and works fine.
Post #1433821
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse