Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

access to report server url Expand / Collapse
Author
Message
Posted Sunday, January 6, 2013 4:49 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Sunday, February 3, 2013 5:31 PM
Points: 16, Visits: 71
Using SQL SERVER 2008r2 Reporting Services. I accessed my report server url using my admin credentials. I used New Role to add my user and gave all permissions in folder settings. I get error " 'servername/user' does not have required permissions. Verify that sufficient permissions have been granted and Windows User Account Control (UAC) restrictions have been addressed."
Also; when I access using admin credentials; I can't run reports. Error saying admin does not have permissions. Where do I assign permissions to the reports I create and deploy.
Thank you
Post #1403375
Posted Sunday, January 6, 2013 11:36 PM


SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: Saturday, September 27, 2014 5:20 AM
Points: 467, Visits: 868
It sounds like you've added permissions on the report server website appropriately, so my first thought is about the datasource connection.

When you are in visual studio (BIDS) you create a datasource. I am wondering what credentials you've used in there. Those will be uploaded to the report server along with the datasource object.

On the report server home page, if you click the 'view details' button over on the right, it reveals the default hidden folder where the datasources are uploaded to. You can then look at the settings for the datasource and see what user credentials it uses.

The ideal way to manage this is to have an AD group in your domain that has very limited database access (read access to specific views or stored procedures used in reports). If your users are part of that group you can then use windows authentication in the datasource settings, and the individual users will pass their own windows credentials through the report server and on to the database. I'm assuming your datasource is SQL Server.

If you aren't able to do (or you are scheduling reports to run unattended) then the next best option is to have a specific reportuser created. I have used DOMAIN\reportuser on certain projects. This is a very limited user where the password does not expire. This user is set up with limited access on the SQL Server database as well as in the Report Server Configuration (ReportServerConfig.exe) on the report server itself - this is required for scheduled reports.

In the datasource properties you can then set it to use this user.

The final possibility is to create a SQL Authentication user on the SQL Database and set the datasource properties to use that user. It's the least recommended way but sometimes unavoidable.

My point in all this is that the folder and report level access granted on the Report Server website is separate from the datasource access. Hope that was clear.

Post #1403421
Posted Monday, January 7, 2013 7:36 AM
Mr or Mrs. 500

Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500Mr or Mrs. 500

Group: General Forum Members
Last Login: Yesterday @ 8:05 AM
Points: 588, Visits: 2,105
There's two places to assign report permissions. #1 is in the site settings and #2 is on the report folder hierarchy. I got caught on this on friday. It had been so long since I've set up a report server.

Then of course there's the access to the DB itself.
Post #1403604
Posted Tuesday, January 8, 2013 5:52 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Sunday, February 3, 2013 5:31 PM
Points: 16, Visits: 71
Thanks so much! Got it
Post #1404509
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse