Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Concerns with Transaction replication parameters Expand / Collapse
Author
Message
Posted Wednesday, January 2, 2013 8:42 PM


Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Yesterday @ 7:13 PM
Points: 1,293, Visits: 1,128
Hi SQL Experts,

We have an OLTP that was configured in P2P replication.

Both the peer nodes were running with SQLserver 2008 R2 SP1. We noticed that one of the DB we have a lot of latency issues and decide to change the readbatchsize from default 500 to 5000. it took 10 hours before we removed the latency. But on the other hand we are seeing a lot of messages in the log reader.

We are using push subscription.

" Approximately 500000 log records have been scanned in pass # 3, 1 of which were marked for replication, elapsed time 6006 (ms).'."

These messages popup every 10 or 15 mts time.

Is these message a real concern for us to look and reduce the readbatchsize parameter.

Will Readbatchthreshold is a better option than readbatchsize?

Can you help me?

Thank you


Post #1402157
Posted Wednesday, January 2, 2013 11:59 PM


Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Today @ 2:02 AM
Points: 1,251, Visits: 1,737
Reduce your readbatchsize, it's too high which is why you're seeing the message:
http://www.sqlservergeeks.com/blogs/Abhay_c/sql-server-bi/455/sql-server-fine-tuning-transactional-replication-performance-part-1

I've read that changing Readbatchthreshold can cause very slow performance in 2008
http://connect.microsoft.com/SQLServer/feedback/details/478792/using-the-readbatchthreshold-parameter-in-logreader-agent-leads-to-slow-performance
Post #1402202
Posted Thursday, January 3, 2013 1:20 AM


Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Yesterday @ 7:13 PM
Points: 1,293, Visits: 1,128
foxxo (1/2/2013)
Reduce your readbatchsize, it's too high which is why you're seeing the message:
http://www.sqlservergeeks.com/blogs/Abhay_c/sql-server-bi/455/sql-server-fine-tuning-transactional-replication-performance-part-1

I'm thinking of changing the readbatchsize parameter from 5000 to 1000. And see if that makes sense.

I've read that changing Readbatchthreshold can cause very slow performance in 2008
http://connect.microsoft.com/SQLServer/feedback/details/478792/using-the-readbatchthreshold-parameter-in-logreader-agent-leads-to-slow-performance


This connect I think is for SQL 2008. Our's is SQLserver 2008 R2 Sp1. This issue would have been resolved. The date of the issue reported is also in 2009. I assume the issue would have been resolved in SQLserver 2008 R2. Thanks for answering the post.
Post #1402218
Posted Thursday, January 3, 2013 6:36 PM


Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Today @ 2:02 AM
Points: 1,251, Visits: 1,737
I'm interested to see if changing those values fixes your issues.

The connect item is old, but the Microsoft comment about readbatchsize being fixed in next release was on Feb 2011, after R2 was already released, so not sure if they're referring to R2 or 2012.
Post #1402632
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse