Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
Log in  ::  Register  ::  Not logged in
Home       Members    Calendar    Who's On

Add to briefcase

Unable to connect to datasource pointing to Dev environment Expand / Collapse
Posted Friday, December 28, 2012 12:05 AM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Monday, December 29, 2014 3:46 AM
Points: 60, Visits: 271
Hi All,

I have a strange issue with SSRS 2005 , The issue is the report works fine from BIDS , but not from the Report Manager.

Envirnoment Details

1. Report Manager is in server 'A'
2. Report Databases are in server 'B'
3. the server i am trying to connect is a different server , say 'C'

So, the data source which i have in my report is pointing to a database in server instance 'C'

the error i get in the report manager when i view it is :

"An error has occurred during report processing.
Cannot create a connection to data source 'ElektraRep'.
For more information about this error navigate to the report server on the local server machine, or enable remote errors "

My try outs

1. i am able to login to the server and to the database with my logins(which i have used for the report) from SSMS.
2.Unable to connect to the server instace (Dev env) from the server , where i have report server.

How would i troubleshoot, breaking my heads

any help would be really appreciated

Chaithanya M
Post #1400806
Posted Wednesday, January 2, 2013 6:44 AM
SSC Journeyman

SSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC Journeyman

Group: General Forum Members
Last Login: Sunday, June 16, 2013 1:45 PM
Points: 76, Visits: 229

Seems to me you suffer the double hop issue; Kerberos not enabled.

To solve this
Option 1:
Enable Kerberos Authentication

Less secure and you use a generic account to access the data source
Option 2:
In ReportManager modify the dataSource credentials to:
'Connect using credentials stored securely in the report server'
Optionally set 'Use as Windows credentials when connecting to the data source'

Hopes this helps,
Regards Kees
Post #1401815
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse