Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Package fails with MaxConcurrentExecutables > 1 Expand / Collapse
Author
Message
Posted Thursday, December 13, 2012 4:23 AM
SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: Thursday, December 18, 2014 12:16 AM
Points: 461, Visits: 693
Hi Guys,

I have a package that runs 21 file loads. The process is run an SQL task to reset some data and then a Bulk insert task to load the data from a flatfileConnection. Each 'pair' of tasks is wrapped in a Sequence Container. When all the sequences have finished then a Send Email task is triggered.

Each of the files has a different schema and therefore needs a different FlatFileConnection

I am trying to run the seqence containers in parallel. The Bulk Insert tasks select their FlatFileConnection dynamically based on the the TaskName. When I run with MaxConcurrentExecutables = 1 everything is fine, when I try to run in Parallel with MaxConcurrentExecutable > 1 (I am on a quad core server) then all but the first Bulk Insert tasks fail with error messages about data not matching in columns which would indicate that it has the wrong Connection. Can anyone shed some light on how to force the connection. I have tried setting delayValidation = True on both the Bulk Insert Task and on the Sequence Container.


Post #1396107
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse