Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

unable to connect to sql server Expand / Collapse
Author
Message
Posted Monday, December 3, 2012 4:54 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Wednesday, June 18, 2014 4:46 AM
Points: 32, Visits: 196
Hi all!

im posting this here since i am, in every sense of the word, a newbie.

We have 3 MS failover clusters at work, totaling 12 instances for production and 26 for test and i can connect to the all but one!

i usually work from a terminal server where all our tools are installed, i do have SSMS installed on my local computer though and if i use the local SSMS and the same credentials as i logon to the terminal server with (my admin account) i CAN connect...

i´ve also asked a colleague to try from the terminal server and she can!

so the problem is related to my account on the terminal server only...

the error message follows:

A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: SSL Provider, error: 0 - The certificate chain was issued by an authority that is not trusted.) (Microsoft SQL Server, Error: -2146893019)

Any ideas?


Post #1391854
Posted Monday, December 3, 2012 7:03 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, February 28, 2014 3:22 AM
Points: 42, Visits: 286
Hello Jaockim,

The error might occur if
a.) Remote connections are not enabled on SQL Server.
b.) The necessary protocols for are not enabled either SQL Server computer or the SQL Server client computer.

If you can login to the Computer running SQL Server,

Login to the instance locally and open properties of the instance
-> Go to Connections and see if Remote connections are allowed
--> Open SQL Server Configuration Manager and see if necessary protocols such as 'Named Pipe, Shared Memory. TCP/IP' are enabled. (You might want to refer to another computer's settings which, you are able to connect remotely.)

Let me know if it helps.
Regards..
Post #1391921
Posted Tuesday, December 4, 2012 6:58 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Wednesday, June 18, 2014 4:46 AM
Points: 32, Visits: 196
thanks for the reply, but its not a setting on the server as my colleague CAN logon from the same terminal server that i am useing.

and I can logon myself from another computer, such as my own workstation, its just that we have alot of scripts and tools on the terminalserver so i would really like to use it since im useing it for everything else!

EDIT: this used to work, something changed during the summer.... but what?!
Post #1392458
Posted Tuesday, December 4, 2012 7:16 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Today @ 6:52 AM
Points: 5,131, Visits: 4,918
It looks like a certificate problem, I would ask the creator of the certificate to provide you with an updated certificate that you can install to the termserver as it looks like the handshaking between termserver, sql, ad, certificate is broken somehow for you to use SSL encryption.



Want an answer fast? Try here
How to post data/code for the best help - Jeff Moden
Need a string splitter, try this - Jeff Moden
How to post performance problems - Gail Shaw
CrossTabs-Part1 & Part2 - Jeff Moden
SQL Server Backup, Integrity Check, and Index and Statistics Maintenance - Ola Hallengren
Managing Transaction Logs - Gail Shaw
Troubleshooting SQL Server: A Guide for the Accidental DBA - Jonathan Kehayias and Ted Krueger

Post #1392471
Posted Tuesday, December 4, 2012 7:19 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Wednesday, June 18, 2014 4:46 AM
Points: 32, Visits: 196
If it where the certificate on the terminal server, wouldnt it be a problem for my colleague to connect aswell?

i am now aware of any certificate that is installed on either the terminal server or the sql server cluster, but i will check it!
Post #1392473
Posted Tuesday, December 4, 2012 7:21 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Today @ 6:52 AM
Points: 5,131, Visits: 4,918
If the certificate is a machine based certificate yes it would affect everyone, but it is more than likely going to be a user based certificate which is why it works for your colleague but not yourself.

http://thesqldude.com/2012/04/21/setting-up-ssl-encryption-for-sql-server-using-certificates-issues-tips-tricks/




Want an answer fast? Try here
How to post data/code for the best help - Jeff Moden
Need a string splitter, try this - Jeff Moden
How to post performance problems - Gail Shaw
CrossTabs-Part1 & Part2 - Jeff Moden
SQL Server Backup, Integrity Check, and Index and Statistics Maintenance - Ola Hallengren
Managing Transaction Logs - Gail Shaw
Troubleshooting SQL Server: A Guide for the Accidental DBA - Jonathan Kehayias and Ted Krueger

Post #1392475
Posted Wednesday, December 5, 2012 1:04 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Wednesday, June 18, 2014 4:46 AM
Points: 32, Visits: 196
SOLVED!

as it turns out, somehow the "encrypt connection" checkbox was checked on this server only, i unchecked it and presto! it works =)

/J
Post #1392822
Posted Wednesday, December 5, 2012 2:37 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Today @ 6:52 AM
Points: 5,131, Visits: 4,918
Most excellent, glad it is working for you.



Want an answer fast? Try here
How to post data/code for the best help - Jeff Moden
Need a string splitter, try this - Jeff Moden
How to post performance problems - Gail Shaw
CrossTabs-Part1 & Part2 - Jeff Moden
SQL Server Backup, Integrity Check, and Index and Statistics Maintenance - Ola Hallengren
Managing Transaction Logs - Gail Shaw
Troubleshooting SQL Server: A Guide for the Accidental DBA - Jonathan Kehayias and Ted Krueger

Post #1392858
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse