Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Database mail saying remote certificate invalid Expand / Collapse
Author
Message
Posted Sunday, October 21, 2012 12:22 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Monday, July 28, 2014 10:40 AM
Points: 47, Visits: 813
Hello Everyone,

I have a crushing issue that i have been looking all over the web, a week ago we moved our mail server to office exchange 365, i reconfigured the mail accounts in database mail profile with the new ones and exchange supports only SSL ports, however the servers on internet are able to access that is behind a firewall but i have another server that is behind NAT, i can open the port 587 for that ip through telnet, but sql server 2008r2 database mail is throwing this error message and not sending any.

Message
The mail could not be sent to the recipients because of the mail server failure. (Sending Mail using Account 1 (2012-10-21T11:34:42). Exception Message: Cannot send mails to mail server. (The remote certificate is invalid according to the validation procedure.).
)

I setup a local outlook client to check if mail can be sent and i got a pop up from remote server to verify a certificate, thinking this was the reason i placed it under Enterprise Root, Trusted Publisher but still sql's database is giving the same odd message, i have enabled it for SSL with correct server, username and password... please help. Thank you.

Regards,
Post #1375147
Posted Tuesday, October 23, 2012 7:00 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Monday, July 28, 2014 10:40 AM
Points: 47, Visits: 813
any body has come across with this problem?
Post #1376013
Posted Tuesday, October 23, 2012 8:03 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Monday, July 28, 2014 10:40 AM
Points: 47, Visits: 813
Hello Everyone!,

I resolved this issue myself.

Whenever the server tried to make contact with exchange it was expecting the remote server to have host name instead of IP, something just barged into my head and i created a Host A record on my server and checked whenever I ping the dns of outlook takes me to the server and it worked!, all i had to do is PUT the exchange 365 smtp dns name and redirect it to the static ip and done, i received the test mail. Thanks.
Post #1376068
Posted Thursday, October 24, 2013 5:41 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Thursday, December 11, 2014 4:09 AM
Points: 22, Visits: 236
Hello,
I am having the same issue, can you please detail steps by steps in what you do to get it working. I am very new at this.
Post #1508301
Posted Thursday, October 24, 2013 10:30 PM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Monday, July 28, 2014 10:40 AM
Points: 47, Visits: 813
I have described the workaround in the second post in the same thread, the cloud exchange does a reverse lookup which is why you have to put the IP address following the dns of your office 365 smtp in the hosts file, i don't work with that company where they used office 365 so i can't exactly remember every steps but i hope i can still help you.
Post #1508322
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse