Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

MSDTC issue in Cluster environment Expand / Collapse
Author
Message
Posted Thursday, August 23, 2012 3:47 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, May 29, 2013 8:06 AM
Points: 167, Visits: 414
Hi All,
I have configured Cluster in my location below are the details of structure.

Q drive 40 GB (Quorum)
S Drive 4 TB (Storage)
M Drive 20 GB (MSDTC)

I tested with Node1 & Node2 (Win Server 2008) both are working fine. Than i installed SQL Cluster on NODE1 and add Node2 in cluster (SQL SERVER 2008) i tested its working very nicely.

ISSUE :- SAN server has been restarted & In my active Node1 showing S & Q drive it not showing M drive. I check with SCSi also not an issue than when i chuck FAIL-OVER CLUSTER ADMINISTRATOR got some errors.

1. Node "1" faild to form a cluster. This was because the witness was
not accessible. Please ensure that the witness resource is online and
available.
Event Id :- 1573

2. Cluster resource "cluster Disk 2" in clustered service or application
'cluster Group' failed.
Event Id :- 1069.

3. Physical drive not detected......
Event Id :- 1034

Let me know the exact issue..

Thanks in advance.

Satish
Post #1348975
Posted Thursday, August 23, 2012 1:50 PM


Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Thursday, July 24, 2014 10:05 AM
Points: 1,288, Visits: 1,846
if SAN was restarted.
Can you offline-online those disk resources?


Alex S
Post #1349336
Posted Thursday, August 23, 2012 10:27 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, May 29, 2013 8:06 AM
Points: 167, Visits: 414
Yes, I did.

After offline & online Quorum & Storage drives came up.

Thanks & Regards
Satish
Post #1349449
Posted Friday, August 24, 2012 9:09 PM


SSC Veteran

SSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC Veteran

Group: General Forum Members
Last Login: Thursday, April 24, 2014 9:12 AM
Points: 285, Visits: 504
I've noticed sometimes that on new cluster setups the servers will lose the drive letter or even use a different one when you failover, especially with iSCSI connections. check disk manager and see if you can find it there as an unlabeled disk. Might have to re-assign the drive letter to it again on both nodes. 20GB for MSDTC seems like an awefully large volume.

---------------------------------------------------------------
Mike Hahn - Future MCM 2025
Right way to ask for help!!
http://www.sqlservercentral.com/articles/Best+Practices/61537/
I post so I can see my avatar
I want a personal webpage
I want to win the lotto
I want a gf like Tiffa
Post #1349992
Posted Monday, August 27, 2012 12:34 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, May 29, 2013 8:06 AM
Points: 167, Visits: 414
Hi Grass,
Yes you are right, my all drives letters are changed but STORAGE & QUORUM are connected. Let me try to change the letter and reassign the MSDTC drive.

Thanks
Satish
Post #1350217
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse