Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Unable attach analsysis service database without detach log file Expand / Collapse
Author
Message
Posted Friday, October 14, 2011 1:12 AM
SSC Veteran

SSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC Veteran

Group: General Forum Members
Last Login: Friday, November 7, 2014 2:15 AM
Points: 206, Visits: 330
Hi
Post recycle of Analysis Service we found one of the database went missing. So we tried attaching it. But its failing with below error:

[highlight=#ffff11]The detach log '\\?\E:\SalesCube_Monthly.0.db\SalesCube_Monthly.detach_log' could not be found in the specified database folder.
The database cannot be attached because an error occurred while loading the detach log from the file '\\?\E:\SalesCube_Monthly.0.db\SalesCube_Monthly.detach_log'. One possible reason is that database is already attached in ReadWrite mode to another server instance.[/highlight]

We did not detach the file, so we this file detach_log did not get created. Is there any other way, we can attach this database ?
Post #1190330
Posted Wednesday, April 10, 2013 11:45 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, April 11, 2013 4:52 AM
Points: 1, Visits: 2
Hi,

Any resolution to this? I am facing the exact same issue today.
Post #1440960
Posted Wednesday, April 10, 2013 8:48 PM
SSC Veteran

SSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC Veteran

Group: General Forum Members
Last Login: Friday, November 7, 2014 2:15 AM
Points: 206, Visits: 330
Nope. We restored cube from the backup
Post #1441090
Posted Tuesday, April 8, 2014 11:33 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Wednesday, July 9, 2014 12:20 AM
Points: 1, Visits: 9
I get the same issue - all Analysis Databases disappeared after a reboot. It would be great if there was a way to attach the databases without detach_log, as there are no backups.

If anyone is aware of a workaround, please share it here. Thanks!
Post #1559788
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse