Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

SSIS - New Connection from Data Source not updating Expand / Collapse
Author
Message
Posted Friday, February 18, 2011 12:35 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Today @ 2:46 PM
Points: 145, Visits: 346
If you set up a Data Source and then created your connections in the Connection managers for your packages and use the option:

"New Connection from Data Source"

It uses the Connection information from the Data Source fine.

But if you then change the Data Source, it doesn't change the connection properties for the Connections in the Connections that are in the Connection Managers for each package in your solution.

If you double click on the connection in the Connection Manager Pane it shows correctly (the same as the Data Source) but if you right click on Connection and select property - it shows the old information and that is what it uses when running the package.

Is there a way to fix this? I have about 30 packages I am running in my solution and need to go back and forth between production and development and have to change all the connection by hand each time I make this change.

Thanks,

Tom
Post #1066578
Posted Thursday, June 28, 2012 12:17 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Tuesday, October 29, 2013 10:09 PM
Points: 7, Visits: 148
I've same problem!.
Did you solved this issue yet ?
Please let me know.
Post #1322283
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse