SSIS, "Class Not Registered" error...deployment or permissions issue?

  • tan110

    Hall of Fame

    Points: 3664

    Where in package properties, do I set run In 64bit = false?

  • Arcturus

    Mr or Mrs. 500

    Points: 563

    After going thru the long list of replies I tried to run it thru CMD

    I modified the job to use cmdexec step and : C:\Program Files (x86)\Microsoft SQL Server\90 \DTS\Binn\DTExec.exe /f "Package Path" /MAXCONCURRENT " -1 " /CHECKPOINTING OFF /REPORTING EW

    And it executed just like you are having a piece of Cake.

    Thanks for the Inputs.

  • tvramanadhan

    Valued Member

    Points: 67

    Hi I am Ramesh from Chennai, India.

    I am also facing the same problem but I am using data source as Excel file. Error displayed as below...

    FirstLine:

    "[Excel Source [17]] Error: SSIS Error Code DTS_E_CANNOTACQUIRECONNECTIONFROMCONNECTIONMANAGER. The AcquireConnection method call to the connection manager "Excel Connection Manager" failed with error code 0xC0202009"

    SecondLine:

    [Connection manager "Excel Connection Manager"] Error: SSIS Error Code DTS_E_OLEDBERROR. An OLE DB error has occurred. Error code: 0x80040154. An OLE DB record is available. Source: "Microsoft OLE DB Service Components" Hresult: 0x80040154 Description: "Class not registered".

    Can any one help me....?:hehe:

  • hubertp2@sbcglobal.net

    SSC Enthusiast

    Points: 166

    Thanks for the info on set 64bit run to false, that fixed my SSIS issues!

  • amirhh2000

    SSChasing Mays

    Points: 660

    First of all I hate SSIS2005 ... it has too many bugs ... (preferably use 2008R2 or 2012)

    Things you can check are as follows:

    1. Make 64bit false

    2. Delay validation = False (in the body of package and on all objects)

    3. EncreptionMethod = SensitiveWithPassword

    4. If you changed number 3 reopen your data connections and re enter username password to be encrypted with the new method.

    5. SQL Agent Service account has access to your Excel/Access datafile location

    6. Create the SQL Job from SSMS2005 not SSMS2008/2012

    7. be patient ... 🙂

    Cheers

    Amir

  • zhasan

    SSC Enthusiast

    Points: 136

    I am able to run the SSIS package just fine by itself, and I am using my sql account. The issue happens when I add it to the SQL server agent to execute, that's when my package fails.

    Any thoughts?

    amirhh2000 (3/24/2014)


    First of all I hate SSIS2005 ... it has too many bugs ... (preferably use 2008R2 or 2012)

    Things you can check are as follows:

    1. Make 64bit false

    2. Delay validation = False (in the body of package and on all objects)

    3. EncreptionMethod = SensitiveWithPassword

    4. If you changed number 3 reopen your data connections and re enter username password to be encrypted with the new method.

    5. SQL Agent Service account has access to your Excel/Access datafile location

    6. Create the SQL Job from SSMS2005 not SSMS2008/2012

    7. be patient ... 🙂

    Cheers

    Amir

  • erinehartjr

    SSC Journeyman

    Points: 79

    I'm not sure if this was ever fixed, but ever time I've run into this error all I've needed to do was load the driver from the following link, and my packages run great.

  • deborah.long

    Valued Member

    Points: 73

    It's a two-fold process to over come this error, but both very simple fixes. I used this post to solve the issue. - http://microsoft-ssis.blogspot.co.uk/2012/09/swtich-package-from-64bit-to-32bit.html

  • intvfan

    Mr or Mrs. 500

    Points: 559

    in the lower left of the validate screen is a Check Box to run 32 Bit.

    This worked for me!

    Changing the setting under DEBUG to 64Bit False did not work for me.

  • Alt7777777

    SSC Enthusiast

    Points: 128

    Hello, just in case this is helpful, I had exactly the same issue, and upgraded the OLE DB provider on the machine I deployed to, and it finally worked.

    https://www.microsoft.com/en-us/download/confirmation.aspx?id=56730

Viewing 10 posts - 46 through 55 (of 55 total)

You must be logged in to reply to this topic. Login to reply