Getting the grid back

  • batgirl (5/16/2014)


    As is often the case, I am now thoroughly confused.

    I am pretty sure that I need a vacation, or at least a long weekend.

    I assumed that "NOT" was typo and was meant to be "NOW". In that case, Control + D was the correct answer for SQL 2012.

    I also assumed "not" should have been "now". Oops :hehe:


    [font="Tahoma"]Personal blog relating fishing to database administration:[/font]

    [font="Comic Sans MS"]https://davegugg.wordpress.com[/url]/[/font]

  • Arrggh, I ticked the wrong box, and apparently got fooled by the documentation. I use this all the time, so I'm guessing I was moving to fast, thinking CTRL+D, but reading the docs and using Shift.

    Points will be awarded back shortly.

  • Igor Micev (5/16/2014)


    CTRL+T - for text

    CTRL+D - for grid

    in my ssms 2008r2, 2012 and 2014.

    And in mine for 2008R2 and 2012.

    Don't understand why all these people are claiming the answer is wrong. Maybe they just haven't noticed that the action for CTRL+D depends on context - if you currently have results to text it switches results to grid. If you already have results to grid, it does something different, namely nothing.

    edit: Ah, I now see that earlier today the wrong answer was right (and there was a wrong word too). I should have read to the end of the discussion to date before commenting (and wouldn't have commented if I had seen Steve's post).

    Tom

  • Steve Jones - SSC Editor (5/16/2014)


    Arrggh, I ticked the wrong box, and apparently got fooled by the documentation. I use this all the time, so I'm guessing I was moving to fast, thinking CTRL+D, but reading the docs and using Shift.

    Points will be awarded back shortly.

    :angry:

  • TomThomson (5/16/2014)edit: Ah, I now see that earlier today the wrong answer was right (and there was a wrong word too). I should have read to the end of the discussion to date before commenting (and wouldn't have commented if I had seen Steve's post).

    Yeah, me too 🙁

  • paul.goldstraw (5/16/2014)

    I had a similar problem with 2012 where using CTRL+R didn't toggle the results window. I followed the advice on this page. Perhaps you're affected in the same way?

    Thanx for that link, it worked for me too, but I don`t recall that I ever changed the default behavior for keyboard shortcuts :w00t:

  • Steve Jones - SSC Editor (5/16/2014)


    Arrggh, I ticked the wrong box, and apparently got fooled by the documentation. I use this all the time, so I'm guessing I was moving to fast, thinking CTRL+D, but reading the docs and using Shift.

    Points will be awarded back shortly.

    Just changing the order of the answers didn't give points back, now it says that the most answered was CTRL+Shift+D but obviously was CTRL+D :-D:-D

  • Easy one, thanks Steve.

    ---------------------------------------------------
    "Thare are only 10 types of people in the world:
    Those who understand binary, and those who don't."

  • Hany Helmy (5/17/2014)


    paul.goldstraw (5/16/2014)

    I had a similar problem with 2012 where using CTRL+R didn't toggle the results window. I followed the advice on this page. Perhaps you're affected in the same way?

    Thanx for that link, it worked for me too, but I don`t recall that I ever changed the default behavior for keyboard shortcuts :w00t:

    Nor did I, it happened for me on a fresh install of SQL 2012 the first time. I wonder if it's related to having versions of Visual Studio installed, causing the shell to get confused. Glad I could help though 😀

  • paul.goldstraw (5/19/2014)


    Hany Helmy (5/17/2014)


    paul.goldstraw (5/16/2014)

    I had a similar problem with 2012 where using CTRL+R didn't toggle the results window. I followed the advice on this page. Perhaps you're affected in the same way?

    Thanx for that link, it worked for me too, but I don`t recall that I ever changed the default behavior for keyboard shortcuts :w00t:

    Nor did I, it happened for me on a fresh install of SQL 2012 the first time. I wonder if it's related to having versions of Visual Studio installed, causing the shell to get confused. Glad I could help though 😀

    hmmm, maybe that`s the reason 🙂

  • Well, I haven't tried it in 2014 but CTRL+D works in 2008R2 so I went for it and got it right.

    ---------------
    Mel. 😎

  • Worst. Question. Ever.

    Now I know that you toggle results to text with a simple CTRL-T. I also know that CTRL-G is going to bring up a goto line number prompt.

    So it leaves me with the remaining 2 options; of which I was fairly certain CTRL-SHIFT-D will bring up the dependency viewer. This leaves CTRL-D.

    I opened up SSMS, toggled results to text, ran the query. then hit the ol' CTRL-D...nothing happened. Results are still going to text. Hit CTRL-SHIFT-D, dependency viewer popped up.

    What am I missing here? I am curious now as to how you can actually achieve this, because not one of the shortcuts listed on msdn, or this question accomplish the task.

  • Koen Verbeeck (5/16/2014)


    Richard Warr (5/16/2014)


    Easy one, thanks.

    You have the only working copy of SQL Server 2012 where CTRL+SHIFT+D actually does something?

    +1

    Not suggesting anything but I see a lot of these Point Gatherer answers.

  • Richard Warr (5/16/2014)


    paul.goldstraw (5/16/2014)


    Koen Verbeeck (5/16/2014)


    Richard Warr (5/16/2014)


    Easy one, thanks.

    You have the only working copy of SQL Server 2012 where CTRL+SHIFT+D actually does something?

    Maybe he's running SQL Server 2012 QOTD Edition? 😉

    No, I'd noticed that the thread didn't have any "Easy one" posts so thought I'd better put one in 🙂

    +1

    Good Answer. Ignore my other comment on "Easy One"

Viewing 14 posts - 31 through 44 (of 44 total)

You must be logged in to reply to this topic. Login to reply