SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


SQL Server Agent failed to start


SQL Server Agent failed to start

Author
Message
- Win.
- Win.
Mr or Mrs. 500
Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)

Group: General Forum Members
Points: 502 Visits: 800
Experts,

Greetings for the day...!!

I have severe problem, please help me to fix this.


I have a box which is with SQL 2005 EE + SP3 updated on Win 2003 + SP2.

Suddenly SQL Server agent failed to start, Log has no such cause and information other than agent shutdown.....

---------------------------
WMI Provider Error
---------------------------
The service did not respond to the start or control request in a timely fashion. [0x8007041d]
---------------------------
OK
---------------------------


cmd:

The application failed to initialize properly (0xc0000005). Click on OK to terminate the application.


No where found the resolution for this..


Can anyone have any ideas...??

Fast help appreciated...


Thanks,
- Win.

Cheers,
- Win.

" Have a great day "
Ramji29
Ramji29
Old Hand
Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)

Group: General Forum Members
Points: 375 Visits: 479
Hi..

Can you plz provide more info on this as.... what exactly happen when the agent wasn't starting?? was it crashed or machine was rebooted or services were rebooted.... plz post the sql error log and sql server entries from event viewer...
- Win.
- Win.
Mr or Mrs. 500
Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)

Group: General Forum Members
Points: 502 Visits: 800
Hi,

It was failed when server was rebooted. And we updated the domain account and password and tried restarting the services, but still it failed.....


Please find the below error log.

2010-06-25 02:52:33 - ? [100] Microsoft SQLServerAgent version 9.00.4035.00 (x86 unicode retail build) : Process ID 5172
2010-06-25 02:52:33 - ? [101] SQL Server REDMOND\XXXX version 9.00.4035 (0 connection limit)
2010-06-25 02:52:33 - ? [102] SQL Server ODBC driver version 9.00.4035
2010-06-25 02:52:33 - ? [103] NetLib being used by driver is DBNETLIB.DLL; Local host server is REDMOND\XXXX
2010-06-25 02:52:33 - ? [310] 8 processor(s) and 4096 MB RAM detected
2010-06-25 02:52:33 - ? [339] Local computer is REDMOND\XXXX running Windows NT 5.2 (3790) Service Pack 1
2010-06-25 02:52:33 - ? [432] There are 11 subsystems in the subsystems cache
2010-06-25 02:52:35 - ! [364] The Messenger service has not been started - NetSend notifications will not be sent
2010-06-25 02:52:35 - ? [129] SQLAgent$REDMOND\XXXX starting under Windows NT service control
2010-06-25 02:52:35 - + [396] An idle CPU condition has not been defined - OnIdle job schedules will have no effect
2010-07-05 11:49:16 - ? [130] SQLAgent$REDMOND\XXXX stopping because of Windows shutdown...
2010-07-05 11:49:23 - ! [165] ODBC Error: 0, Driver's SQLAllocHandle on SQL_HANDLE_ENV failed [SQLSTATE IM004]
2010-07-05 11:49:23 - ! [382] Logon to server 'REDMOND\XXXX' failed (SaveAllSchedules)
2010-07-05 11:49:32 - ! [359] The local host server is not running
2010-07-05 11:49:32 - ? [098] SQLServerAgent terminated (normally)

Cheers,
- Win.

" Have a great day "
- Win.
- Win.
Mr or Mrs. 500
Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)

Group: General Forum Members
Points: 502 Visits: 800
Any suggestions please..........

Cheers,
- Win.

" Have a great day "
Ramji29
Ramji29
Old Hand
Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)

Group: General Forum Members
Points: 375 Visits: 479
- Win. (8/17/2010)
Hi,

It was failed when server was rebooted. And we updated the domain account and password and tried restarting the services, but still it failed.....


Please find the below error log.

2010-06-25 02:52:33 - ? [100] Microsoft SQLServerAgent version 9.00.4035.00 (x86 unicode retail build) : Process ID 5172
2010-06-25 02:52:33 - ? [101] SQL Server REDMOND\XXXX version 9.00.4035 (0 connection limit)
2010-06-25 02:52:33 - ? [102] SQL Server ODBC driver version 9.00.4035
2010-06-25 02:52:33 - ? [103] NetLib being used by driver is DBNETLIB.DLL; Local host server is REDMOND\XXXX
2010-06-25 02:52:33 - ? [310] 8 processor(s) and 4096 MB RAM detected
2010-06-25 02:52:33 - ? [339] Local computer is REDMOND\XXXX running Windows NT 5.2 (3790) Service Pack 1
2010-06-25 02:52:33 - ? [432] There are 11 subsystems in the subsystems cache
2010-06-25 02:52:35 - ! [364] The Messenger service has not been started - NetSend notifications will not be sent
2010-06-25 02:52:35 - ? [129] SQLAgent$REDMOND\XXXX starting under Windows NT service control
2010-06-25 02:52:35 - + [396] An idle CPU condition has not been defined - OnIdle job schedules will have no effect
2010-07-05 11:49:16 - ? [130] SQLAgent$REDMOND\XXXX stopping because of Windows shutdown...
2010-07-05 11:49:23 - ! [165] ODBC Error: 0, Driver's SQLAllocHandle on SQL_HANDLE_ENV failed [SQLSTATE IM004]
2010-07-05 11:49:23 - ! [382] Logon to server 'REDMOND\XXXX' failed (SaveAllSchedules)
2010-07-05 11:49:32 - ! [359] The local host server is not running
2010-07-05 11:49:32 - ? [098] SQLServerAgent terminated (normally)


Does mssql service also running under this account??? just for testing purpose change the srvice account to local or add the service account to local admin (although its not recommended) but this will confimr if this is due to any permissions issues.... secondly have u added this new domain login for having "log on as service" rights??

Tell me if this helps.

Rohit
- Win.
- Win.
Mr or Mrs. 500
Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)

Group: General Forum Members
Points: 502 Visits: 800
Hi Rohit,

Tested all the things with accounts and permissions. Still no use...

Its throwing the same error.



- Win.

Cheers,
- Win.

" Have a great day "
- Win.
- Win.
Mr or Mrs. 500
Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)Mr or Mrs. 500 (502 reputation)

Group: General Forum Members
Points: 502 Visits: 800
SQL Server Services are running fine with the same account.

Cheers,
- Win.

" Have a great day "
Ramji29
Ramji29
Old Hand
Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)Old Hand (375 reputation)

Group: General Forum Members
Points: 375 Visits: 479
- Win. (8/17/2010)
Hi,

It was failed when server was rebooted. And we updated the domain account and password and tried restarting the services, but still it failed.....


Please find the below error log.

2010-06-25 02:52:33 - ? [100] Microsoft SQLServerAgent version 9.00.4035.00 (x86 unicode retail build) : Process ID 5172
2010-06-25 02:52:33 - ? [101] SQL Server REDMOND\XXXX version 9.00.4035 (0 connection limit)
2010-06-25 02:52:33 - ? [102] SQL Server ODBC driver version 9.00.4035
2010-06-25 02:52:33 - ? [103] NetLib being used by driver is DBNETLIB.DLL; Local host server is REDMOND\XXXX
2010-06-25 02:52:33 - ? [310] 8 processor(s) and 4096 MB RAM detected
2010-06-25 02:52:33 - ? [339] Local computer is REDMOND\XXXX running Windows NT 5.2 (3790) Service Pack 1
2010-06-25 02:52:33 - ? [432] There are 11 subsystems in the subsystems cache
2010-06-25 02:52:35 - ! [364] The Messenger service has not been started - NetSend notifications will not be sent
2010-06-25 02:52:35 - ? [129] SQLAgent$REDMOND\XXXX starting under Windows NT service control
2010-06-25 02:52:35 - + [396] An idle CPU condition has not been defined - OnIdle job schedules will have no effect
2010-07-05 11:49:16 - ? [130] SQLAgent$REDMOND\XXXX stopping because of Windows shutdown...
2010-07-05 11:49:23 - ! [165] ODBC Error: 0, Driver's SQLAllocHandle on SQL_HANDLE_ENV failed [SQLSTATE IM004]
2010-07-05 11:49:23 - ! [382] Logon to server 'REDMOND\XXXX' failed (SaveAllSchedules)
2010-07-05 11:49:32 - ! [359] The local host server is not running
2010-07-05 11:49:32 - ? [098] SQLServerAgent terminated (normally)


See to be honest your log doesn't seems to be complete and of today's date (25th June & 5th July)... did you checked the logs after you did your tests just now???
John Mitchell-245523
John Mitchell-245523
SSChampion
SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)

Group: General Forum Members
Points: 14183 Visits: 15963
Win

Since you're getting Logon to server 'REDMOND\XXXX' failed, I would guess that your SQL Server Agent doesn't have permission to log on. Have a look under Logins, and check that the SQL Server Account is there, or that a group of which it is a member is there. If you set up SQL Server to record failed logins then the login failure will also appear in the SQL Errorlog, along with the name of the login for which logon failed.

John
Perry Whittle
Perry Whittle
SSC-Insane
SSC-Insane (20K reputation)SSC-Insane (20K reputation)SSC-Insane (20K reputation)SSC-Insane (20K reputation)SSC-Insane (20K reputation)SSC-Insane (20K reputation)SSC-Insane (20K reputation)SSC-Insane (20K reputation)

Group: General Forum Members
Points: 20004 Visits: 17243
- Win. (8/17/2010)
And we updated the domain account and password


what tool did you use to update the service account username and password?

Services snapin
SQL Server Config Manager

-----------------------------------------------------------------------------------------------------------

"Ya can't make an omelette without breaking just a few eggs" ;-)
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search