I'd have liked to see a 4th option, "none of the above". I believe that would have added to the educational opportunity.
But then, why pose this question at all? Doesn't it promote harder to read code, and the memorization of what is essentially trivia?
select * from table_name
I'd argue that the above statement is: easier to read, doesn't require knowledge of this trivia, works if you substitue "my_column" for the "*", and is probably far more cross platform compatible.
These are meant as constructive criticisms. I do very much appreciate the learning opportunity!