SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Getting "OLE DB provider "STREAM" for linked server "(null)" returned message "Query timeout...


Getting "OLE DB provider "STREAM" for linked server "(null)" returned message "Query timeout expired"."

Author
Message
Arshad Ali-556241
Arshad Ali-556241
SSC-Enthusiastic
SSC-Enthusiastic (176 reputation)SSC-Enthusiastic (176 reputation)SSC-Enthusiastic (176 reputation)SSC-Enthusiastic (176 reputation)SSC-Enthusiastic (176 reputation)SSC-Enthusiastic (176 reputation)SSC-Enthusiastic (176 reputation)SSC-Enthusiastic (176 reputation)

Group: General Forum Members
Points: 176 Visits: 194
Hi,

We have two servers, backend and frontend. Frontend server has all the data and transformation logics in SSIS (METaL system) and we are executing it from backend server. We have set up linked server across SQL Servers and set Query time property to 0. When we execute this application it works fine for small set of data and completes in 4-5 minutes but starts failing if we run it for huge data set which takes somewhere around 11-12 minutes.

OLE DB provider "STREAM" for linked server "(null)" returned message "Query timeout expired".
Msg 0, Level 11, State 0, Line 0
A severe error occurred on the current command. The results, if any, should be discarded.


Please help us, it’s becoming a bit critical for us. Thanks in advance.

With Thanks and Regards
Arshad Ali
Microsoft India

My Blog - http://arshadali.blogspot.com/
Mike in Minn
Mike in Minn
Grasshopper
Grasshopper (10 reputation)Grasshopper (10 reputation)Grasshopper (10 reputation)Grasshopper (10 reputation)Grasshopper (10 reputation)Grasshopper (10 reputation)Grasshopper (10 reputation)Grasshopper (10 reputation)

Group: General Forum Members
Points: 10 Visits: 118
Did you get an answer to your problem? We got the same error last night using a linked server. We are looking at increasing the remote_query_timeout setting in SP_configure.
Arshad Ali-556241
Arshad Ali-556241
SSC-Enthusiastic
SSC-Enthusiastic (176 reputation)SSC-Enthusiastic (176 reputation)SSC-Enthusiastic (176 reputation)SSC-Enthusiastic (176 reputation)SSC-Enthusiastic (176 reputation)SSC-Enthusiastic (176 reputation)SSC-Enthusiastic (176 reputation)SSC-Enthusiastic (176 reputation)

Group: General Forum Members
Points: 176 Visits: 194
Yes we resolved it by changing the default value.

Right click on Server in Object Explorer of SSMS, then click on Properties, go to Connection page and change the Remote-Query timeout setting to something more as per your need from 600. You can also specify 0 if you want "no timeout" setting.

With Thanks and Regards
Arshad Ali
Microsoft India

My Blog - http://arshadali.blogspot.com/
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search