Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Missing green arrow on the sql server icon in object explore


Missing green arrow on the sql server icon in object explore

Author
Message
lou 43158
lou 43158
Forum Newbie
Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)

Group: General Forum Members
Points: 1 Visits: 7
Hi,

I resolved the isssue in Win2K8 by running MSSMS as and administartor. Even though you have local admin access to the Server the issue still persists. I think it is caused by having UAC enabled. Hope this helps.
Schadenfreude-Mei
Schadenfreude-Mei
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1129 Visits: 1336
Thanks for the reply but I am using XP (so UAC wouldnt be involved) and while I am not logged in as Administrator my AD account is an admin of my machine and all SQL boxes.

Thanks anyway.

Adam Zacks

-------------------------------------------

Be Nice, Or Leave
bbrown 40722
bbrown 40722
Forum Newbie
Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)

Group: General Forum Members
Points: 2 Visits: 4
I am having the same problem. I am running Windows 2003 R2 SP2 and SQL 2005. It was working fine, but IT upgraded the server from Standard to Enterprise. Any suggestions. I have tried everything on this post.
Schadenfreude-Mei
Schadenfreude-Mei
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1129 Visits: 1336
What is you issue?
This thread is about using a SQL Server 2005 Ent 64-bit A/P cluster through SSMS 2008. Your issue sounds different.

Start from the begining, what are the details?

Adam Zacks

-------------------------------------------

Be Nice, Or Leave
bbrown 40722
bbrown 40722
Forum Newbie
Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)

Group: General Forum Members
Points: 2 Visits: 4
My issue is the same as the first post " I can't use right-click the instance icon to select "start", "stop", "pause", "resume" or "restart" because they are all grayed out. But all the rest operations are available" I don't think it is related to a specific version. I found something yesterday that I am going to try that says it is related to the SQL clinet.
Schadenfreude-Mei
Schadenfreude-Mei
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1129 Visits: 1336
bbrown 40722 (7/12/2011)
My issue is the same as the first post " I can't use right-click the instance icon to select "start", "stop", "pause", "resume" or "restart" because they are all grayed out. But all the rest operations are available" I don't think it is related to a specific version. I found something yesterday that I am going to try that says it is related to the SQL clinet.


If that your issue, it is likely to be permissions related. What you need to have is access to view the 'Server State'.

The first thing to try is to run ssms and connect to the instance as the login used for the sql service (assuming its a domain account). That should work fine.

Now check that the same account has been setup for lock pages in memory, do this: Run:gpedit.msc --> Computer Config --> Windows Settings --> Security Settings --> Local Policies --> User Rights and ensure that Lock Pages in Memory is set to the same account as you service account (this will have to be a domain account).

Once that is done get your user or dba group (if multiple users) setup in the local admin group of the server. Really all you should need is access to Services but it never hurts to have Admin (for backup file permissions and various others).

Let me know and good luck.

Adam Zacks

-------------------------------------------

Be Nice, Or Leave
Omo Eko
Omo Eko
Forum Newbie
Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)

Group: General Forum Members
Points: 7 Visits: 115
I know this is years late, but i was under the impression the green arrow had to do with the state of SQL Server Agent configuration. Can anyone give clarity on this. I just wanted to clarify this.
brixton
brixton
Forum Newbie
Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)

Group: General Forum Members
Points: 3 Visits: 38
Permissions are consistent across all servers, regardless of OS/version. Service control state is inconsistent regardless of OS/version.
Gavin Heer
Gavin Heer
Grasshopper
Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)Grasshopper (16 reputation)

Group: General Forum Members
Points: 16 Visits: 362
I still cannot get this to work on my local SSMS client. It's running the same version as on the server. My problem pertains to clustered instances running 2K8 R2 Enterprise. I can gain control of he services state locally on my wkstn if I register the physical cluster node name but the virtual name just gives me the circle. The weird thing is I log onto the virtual host name and connect to the instance and all is well there. Just not my local 2005 client. Any idea on what I have to tweak on my local client in SSMS or within windows to get this to work (green arrow) so I can control all aspects of services and more importantly SSCM. The exact error message i get when accessing SSCM is below.

Cannot connect to WMI provider. You do not have permission or the server is unreachable. Note that you can only manage SQL Server 2005 servers with SQL Server Configuration manager. The RPC server is unavailable [0x800706ba]

Any clues?
Dave Bicknell
Dave Bicknell
Forum Newbie
Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)

Group: General Forum Members
Points: 5 Visits: 1164
I had the same issue in SSMS and also while using Central Management Server. I found if i had registered the instance with the port defined, for example: SQLHost\Instance, 1433, I got the white circle and could not control the services from there. If I remove the port portion, I get the green arrow and I am able to control the services. Just figured I'd chime in, since this fixed my issue. BTW, I am connecting to SQL 2000, 2005, 2008 and 2008 R2. All of them had the same issue.
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search