SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Changing Authentication mode of connecting to Integration Services


Changing Authentication mode of connecting to Integration Services

Author
Message
Aspet Golestanian Namagerdi
Aspet Golestanian Namagerdi
Right there with Babe
Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)

Group: General Forum Members
Points: 798 Visits: 862
In Managment studio(SQL SERVER 2008),I am trying to connect to Integration Services.But it is always in windows Authetication and I can not chnage it to SQL authentication .My login is sysadmin, but when I am trying to connect in window Authentication it says access denied.
1-How is it possible to change the authentication mode to SQL Authentication of cnnecting to SQL SERVER 2008 Intgration Services?
2-why my login (sysadmin) can not access to Integration Services and How can I give this permission to my user?

Thanks
simon.ciglia
simon.ciglia
SSC-Enthusiastic
SSC-Enthusiastic (101 reputation)SSC-Enthusiastic (101 reputation)SSC-Enthusiastic (101 reputation)SSC-Enthusiastic (101 reputation)SSC-Enthusiastic (101 reputation)SSC-Enthusiastic (101 reputation)SSC-Enthusiastic (101 reputation)SSC-Enthusiastic (101 reputation)

Group: General Forum Members
Points: 101 Visits: 66
me too!
Gift Peddie
Gift Peddie
SSCoach
SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)

Group: General Forum Members
Points: 16548 Visits: 14456
Aspet Golestanian Namagerdi (10/25/2009)
In Managment studio(SQL SERVER 2008),I am trying to connect to Integration Services.But it is always in windows Authetication and I can not chnage it to SQL authentication .My login is sysadmin, but when I am trying to connect in window Authentication it says access denied.
1-How is it possible to change the authentication mode to SQL Authentication of cnnecting to SQL SERVER 2008 Intgration Services?
2-why my login (sysadmin) can not access to Integration Services and How can I give this permission to my user?

Thanks


If your SQL Server is Windows authentication you cannot change authentication at the point of connection, you must configure mixed authentication before trying to connect. In SQL Server at the top right click and go to server properties under security change to both SQL Server and Windows authentication and you can use SQL authentication to connect to SSIS.

Kind regards,
Gift Peddie
Aspet Golestanian Namagerdi
Aspet Golestanian Namagerdi
Right there with Babe
Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)

Group: General Forum Members
Points: 798 Visits: 862
Thx for reply,But the SQL Server is on "SQL SERVER and Windows Authentication mode",but still I can chnage it during connecting to Integration Services.
Gift Peddie
Gift Peddie
SSCoach
SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)

Group: General Forum Members
Points: 16548 Visits: 14456
Aspet Golestanian Namagerdi (10/26/2009)
Thx for reply,But the SQL Server is on "SQL SERVER and Windows Authentication mode",but still I can chnage it during connecting to Integration Services.


If SQL Server is in both Windows and SQL Server mode you should be able to use SQL Server authentication if you cannot use it then the system admin account is disabled when you installed SQL Server with Windows authentication so you need to enable it. Check the links below for details and how to enable it.

http://msdn.microsoft.com/en-us/library/ms188670.aspx

http://blog.sqlauthority.com/2008/12/24/sql-server-disable-and-enable-user-sa/

Kind regards,
Gift Peddie
Aspet Golestanian Namagerdi
Aspet Golestanian Namagerdi
Right there with Babe
Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)

Group: General Forum Members
Points: 798 Visits: 862
Thanks alot for th replys.
I guess I found the answer.Please refer to the link
http://technet.microsoft.com/en-us/library/ms180068.aspx
but How can I give this permission(Connecting to intigration Services) to a user
Gift Peddie
Gift Peddie
SSCoach
SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)

Group: General Forum Members
Points: 16548 Visits: 14456
Aspet Golestanian Namagerdi (10/26/2009)
Thanks alot for th replys.
I guess I found the answer.Please refer to the link
http://technet.microsoft.com/en-us/library/ms180068.aspx
but How can I give this permission(Connecting to intigration Services) to a user


That is related to connection within SQL Server Management Studio but if you are connecting in BIDs the development tool you can change authentication mode as needed.

Which is default depends if your data source is SQL Server or other RDBMS.

Kind regards,
Gift Peddie
Aspet Golestanian Namagerdi
Aspet Golestanian Namagerdi
Right there with Babe
Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)

Group: General Forum Members
Points: 798 Visits: 862
I know,My question is related to Managment studio environment.Now,how can I give the right of access to "Integration Service" to an windows account.Actually this will solve my problem.

Thanks
Gift Peddie
Gift Peddie
SSCoach
SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)SSCoach (16K reputation)

Group: General Forum Members
Points: 16548 Visits: 14456
Aspet Golestanian Namagerdi (10/26/2009)
I know,My question is related to Managment studio environment.Now,how can I give the right of access to "Integration Service" to an windows account.Actually this will solve my problem.

Thanks


It will only solve the problem if mixed mode is not used to develop packages in BIDs you have to remember that because these issues can take a long time to resolve if the connection to the base problem is not addressed.

Kind regards,
Gift Peddie
Aspet Golestanian Namagerdi
Aspet Golestanian Namagerdi
Right there with Babe
Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)Right there with Babe (798 reputation)

Group: General Forum Members
Points: 798 Visits: 862
Thx,But How can I give the right of access to "Integration Service" to an windows account
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search