SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


SQL Error 15128


SQL Error 15128

Author
Message
Patti Johnson
Patti Johnson
SSCertifiable
SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)

Group: General Forum Members
Points: 6437 Visits: 950
Receive the error 15128 because MUST_CHANGE is on. How to get around this. This is a sql acocunt and should not have a password that expires.
Roy Ernest
Roy Ernest
SSC-Dedicated
SSC-Dedicated (34K reputation)SSC-Dedicated (34K reputation)SSC-Dedicated (34K reputation)SSC-Dedicated (34K reputation)SSC-Dedicated (34K reputation)SSC-Dedicated (34K reputation)SSC-Dedicated (34K reputation)SSC-Dedicated (34K reputation)

Group: General Forum Members
Points: 34152 Visits: 6916
Remove the Enforce password policy. You can use the GUI to do that.

-Roy
Patti Johnson
Patti Johnson
SSCertifiable
SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)

Group: General Forum Members
Points: 6437 Visits: 950
Do you mean the SQL GUI?
Roy Ernest
Roy Ernest
SSC-Dedicated
SSC-Dedicated (34K reputation)SSC-Dedicated (34K reputation)SSC-Dedicated (34K reputation)SSC-Dedicated (34K reputation)SSC-Dedicated (34K reputation)SSC-Dedicated (34K reputation)SSC-Dedicated (34K reputation)SSC-Dedicated (34K reputation)

Group: General Forum Members
Points: 34152 Visits: 6916
SSMS SQL Server Management studio. Or you can do it using T-SQL. ALTER LOGIN

-Roy
Patti Johnson
Patti Johnson
SSCertifiable
SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)SSCertifiable (6.4K reputation)

Group: General Forum Members
Points: 6437 Visits: 950
I tried both ways alter login and then ssms. Both ways gave me the error.

This is what I did to get around the issue.

I logged in to SSMS using the sql account. When prompted to change the password I did. The sql account had sysadmin role. I opened up the sql account login and unchecked the 2 options for password expiration and the other option and it worked without error.

with all that said, I am wondering if it has something to do with the security of the user who logged that defined the sql account. That login should have been able to make that change.
Brian Kelley
Brian Kelley
Keeper of the Duck
Keeper of the Duck (94K reputation)

Group: Moderators
Points: 94075 Visits: 1926
The interface has to be aware of the password change ability. So if you're using an older client (not SQL Server Native Client), they'll get the error that says they can't login, but they won't be able to do so because that interface won't present the change password prompt.

K. Brian Kelley
@kbriankelley
henid
henid
Valued Member
Valued Member (73 reputation)Valued Member (73 reputation)Valued Member (73 reputation)Valued Member (73 reputation)Valued Member (73 reputation)Valued Member (73 reputation)Valued Member (73 reputation)Valued Member (73 reputation)

Group: General Forum Members
Points: 73 Visits: 413
What you also can do:
- In MSSMS
- Activate the user property
- change to a temporary password then save and close
- activate again and then disable Enforce Password
- than save with the original password

Enjoy!
perl1
perl1
SSC-Enthusiastic
SSC-Enthusiastic (118 reputation)SSC-Enthusiastic (118 reputation)SSC-Enthusiastic (118 reputation)SSC-Enthusiastic (118 reputation)SSC-Enthusiastic (118 reputation)SSC-Enthusiastic (118 reputation)SSC-Enthusiastic (118 reputation)SSC-Enthusiastic (118 reputation)

Group: General Forum Members
Points: 118 Visits: 16
HI Thank you so much this this worked for me ...:-)
Lidia Joubert
Lidia Joubert
SSC Veteran
SSC Veteran (285 reputation)SSC Veteran (285 reputation)SSC Veteran (285 reputation)SSC Veteran (285 reputation)SSC Veteran (285 reputation)SSC Veteran (285 reputation)SSC Veteran (285 reputation)SSC Veteran (285 reputation)

Group: General Forum Members
Points: 285 Visits: 101
Thanks Patti - you saved what is left of my sanity.
chirag.patel19
chirag.patel19
SSC Journeyman
SSC Journeyman (78 reputation)SSC Journeyman (78 reputation)SSC Journeyman (78 reputation)SSC Journeyman (78 reputation)SSC Journeyman (78 reputation)SSC Journeyman (78 reputation)SSC Journeyman (78 reputation)SSC Journeyman (78 reputation)

Group: General Forum Members
Points: 78 Visits: 163
//** Use this query and you will all set**//txtPost_CommentEmoticon(':-)');

USE Master
GO
ALTER LOGIN SQL_Account WITH PASSWORD = ‘currentpassword(SamePassword)’
GO
ALTER LOGIN SQL_Account WITH
CHECK_POLICY = OFF,
CHECK_EXPIRATION = OFF;:-)
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum








































































































































































SQLServerCentral


Search