SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Poor Man's Enterprise Feature - Lock Pages in Memory


Poor Man's Enterprise Feature - Lock Pages in Memory

Author
Message
Paul White
Paul White
SSCoach
SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)

Group: General Forum Members
Points: 15482 Visits: 11354
Charles Hottle (9/20/2010)
Is this update required for an environment running SQL Server 2008 SP1 Standard 32-bit using AWE and PAE in order for Lock Pages in Memory to be functional? I only see 64-bit referenced in the various posts that I've seen. Thanks.

No the update is for 64-bit only.
See http://blogs.msdn.com/b/psssql/archive/2009/09/11/fun-with-locked-pages-awe-task-manager-and-the-working-set.aspx



Paul White
SQLPerformance.com
SQLblog.com
@SQL_Kiwi
brown-415622
brown-415622
Grasshopper
Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)

Group: General Forum Members
Points: 14 Visits: 36
When adding the -T846 where exactly do add the parameter at the very begining? Can you please show an
example, it would be well appreciated.

Thank you
Paul White
Paul White
SSCoach
SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)

Group: General Forum Members
Points: 15482 Visits: 11354
brown-415622 (9/25/2010)
When adding the -T846 where exactly do add the parameter at the very begining? Can you please show an example, it would be well appreciated.

The trace flag is 845 not 846.

You need 2005 64-bit Standard at least SP3 + Cumulative Update 4, or 2008 64-bit Standard at least SP1 + Cumulative Update 2:
http://support.microsoft.com/kb/970070

Here is a link showing how to set it as a start-up option:
http://blogs.msdn.com/b/psssql/archive/2010/02/19/did-you-start-your-sql-server-engine-correctly.aspx

How to know your system is now using Locked Pages successfully:
http://blogs.msdn.com/b/psssql/archive/2007/10/18/do-i-have-to-assign-the-lock-privilege-for-local-system.aspx

How to configure start-up options (general info):
http://msdn.microsoft.com/en-us/library/ms345416.aspx

Using start-up options:
http://msdn.microsoft.com/en-us/library/ms190737.aspx



Paul White
SQLPerformance.com
SQLblog.com
@SQL_Kiwi
brown-415622
brown-415622
Grasshopper
Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)

Group: General Forum Members
Points: 14 Visits: 36
I have read all the documentation my issue is I'm not sure where to put the -T845 parameter
at startup.


-ll:\masterdb\mastlog.ldf;-el:\LOG\ERRORLOG;-dl:\masterdb\master.mdf

Does it go at the begining? I keep getting an error when restart SQL service.

running 64 bit standard 2005 with cumm patch 11.

Thanks
Paul White
Paul White
SSCoach
SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)SSCoach (15K reputation)

Group: General Forum Members
Points: 15482 Visits: 11354
brown-415622 (9/25/2010)
I have read all the documentation my issue is I'm not sure where to put the -T845 parameter at startup.Thanks

Well excuse me! You didn't give that impression by quoting the wrong number :-P
It goes at the end.
edit: exactly as shown in the picture in the link I gave: http://blogs.msdn.com/b/psssql/archive/2010/02/19/did-you-start-your-sql-server-engine-correctly.aspx

Doze



Paul White
SQLPerformance.com
SQLblog.com
@SQL_Kiwi
brown-415622
brown-415622
Grasshopper
Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)

Group: General Forum Members
Points: 14 Visits: 36
Thanks for your help, it worked.
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search