SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Reporting Services Error


Reporting Services Error

Author
Message
AAkula
AAkula
SSCarpal Tunnel
SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)

Group: General Forum Members
Points: 4920 Visits: 674
Hi,
We installed SQL Server 2005 reporting services as below

1.Installed the reporting services 64 bit with file only option (installation path d:\microsoft sql server) - Successful
2.Installed SP3 64 bit - Successful
3.Configured the Reporting Services using Report server Configuration manager - Successfull
4.http://localhost/reportserver - Microsoft SQL Server Reporting Services Version 9.00.4035.00
5.http://localhost/reports - here Iam getting the following error

Server Error in '/Reports' Application.
--------------------------------------------------------------------------------

An error occurred while parsing the configuration file. The ReportServerVirtualDirectory element is missing.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Exception: An error occurred while parsing the configuration file. The ReportServerVirtualDirectory element is missing.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:


[Exception: An error occurred while parsing the configuration file. The ReportServerVirtualDirectory element is missing.]
Microsoft.ReportingServices.Diagnostics.RSConfiguration.ThrowElementMissing(String element) +74
Microsoft.ReportingServices.Diagnostics.UIConfiguration.ParseXML(XmlNode node, RSConfiguration configObject) +1640
Microsoft.ReportingServices.Diagnostics.RSConfiguration.ParseDocument() +1270
Microsoft.ReportingServices.Diagnostics.RSConfiguration.Load() +90

[ServerConfigurationErrorException: The report server has encountered a configuration error. See the report server log files for more information.]
Microsoft.ReportingServices.Diagnostics.RSConfiguration.Load() +316
Microsoft.ReportingServices.Diagnostics.RSConfigurationManager..ctor(String configFileName, String configLocation) +191
Microsoft.ReportingServices.UI.Global.get_ConfigurationManager() +157
Microsoft.ReportingServices.UI.GlobalApp.Application_Start(Object sender, EventArgs e) +52




--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433



Please advice me
AAkula
AAkula
SSCarpal Tunnel
SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)

Group: General Forum Members
Points: 4920 Visits: 674
Yeah,
I cracked the mistry as below.It all about modifying the RSWebApplication.config file in Reportmanager.
Steps:
1. I compared the currently running reporting services configurarion with my newly installed Reporting services
2. I checked the RSWebApplication.config file in Reportmanager in currently running Server. It is as below
Code Snippet
Configuration
UI
ReportServerUrl></ ReportServerUrl
ReportServerVirtualDirectory>ReportServer</ReportServerVirtualDirectory
ReportBuilderTrustLevel>FullTrust</ReportBuilderTrustLevel
/UI

3.I checked the RSWebApplication.config file in Reportmanager in newly installed server. It is as below
Code Snippet
Configuration
UI
ReportServerUrl></ReportServerUrl
ReportServerVirtualDirectory>/ReportServerVirtualDirectory
ReportBuilderTrustLevel>FullTrust</ReportBuilderTrustLevel
/UI
4. Compare 2 n 3. In 3, ReportServer is missing (in the quoted line)

5. I added the ReportServer in step 3.

6.Everything is working fine now.

BUT WHY THE INSTALLATION DID NOT INSTALLED CORRECTLY IN THE NEW SERVER? ANY IDEA? ANY KIND OF BUG?


I appreciate your inputs

Thanks
AAkula
AAkula
SSCarpal Tunnel
SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)

Group: General Forum Members
Points: 4920 Visits: 674
Yeah,
I cracked the mistry as below.It all about modifying the RSWebApplication.config file in Reportmanager.
Steps:
1. I compared the currently running reporting services configurarion with my newly installed Reporting services
2.I checked the RSWebApplication.config file in Reportmanager in currently running Server. It is as below
Code Snippet
Configuration
UI
ReportServerUrl></ ReportServerUrl
ReportServerVirtualDirectory>ReportServer</ReportServerVirtualDirectory
ReportBuilderTrustLevel>FullTrust</ReportBuilderTrustLevel
/UI

3.I checked the RSWebApplication.config file in Reportmanager in newly installed server. It is as below
Code Snippet
Configuration
UI
ReportServerUrl></ReportServerUrl

ReportServerVirtualDirectory>/ReportServerVirtualDirectory
ReportBuilderTrustLevel>FullTrust</ReportBuilderTrustLevel
/UI

4. Compare 2 n 3. In 3, ReportServer is missing see the quoted line above.

5. I added the ReportServer in step 3.

6.Everything is working fine now.

BUT WHY THE INSTALLATION DID NOT INSTALLED CORRECTLY IN THE NEW SERVER? ANY IDEA? ANY KIND OF BUG?


I appreciate your inputs

Thanks
AAkula
AAkula
SSCarpal Tunnel
SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)

Group: General Forum Members
Points: 4920 Visits: 674
hi,

I do not know why some of the code is missing here. Iam typing here again
Yeah,

2.

3.
AAkula
AAkula
SSCarpal Tunnel
SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)SSCarpal Tunnel (4.9K reputation)

Group: General Forum Members
Points: 4920 Visits: 674
2.
3.
jeff.slee
jeff.slee
SSC Journeyman
SSC Journeyman (95 reputation)SSC Journeyman (95 reputation)SSC Journeyman (95 reputation)SSC Journeyman (95 reputation)SSC Journeyman (95 reputation)SSC Journeyman (95 reputation)SSC Journeyman (95 reputation)SSC Journeyman (95 reputation)

Group: General Forum Members
Points: 95 Visits: 0
Thanks a lot. I made the changes in the RSWebApplication.config as you indicated. The report manager is now loading correctly. There is definitely an error in the code.

I haven't a clue about programming and was pulling my hair out.

Just wanted to say thanks!!!!!!


Jeff
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum









































































































































































SQLServerCentral


Search