SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Report Server not recognized email aliases


Report Server not recognized email aliases

Author
Message
adams.squared
adams.squared
Mr or Mrs. 500
Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)

Group: General Forum Members
Points: 527 Visits: 441
I have setup the report services and most of it seems to be working fine. When I create a subscription, the email is populated with the username, aadams for example. The problem is that when the subscription is executed it fails because of an invalid email address. If I add the rest of the mail, aadams@company.com, then it works just fine. Why isn't RS recognizing email aliases and where would I look to resolve this?
Thanks
Michael Valentine Jones
Michael Valentine Jones
SSChampion
SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)SSChampion (14K reputation)

Group: General Forum Members
Points: 14449 Visits: 11848
You cannot use an Exchange server email alias.

Reporting services uses only SMTP format email addresses, so it must be in the form name@company.com
adams.squared
adams.squared
Mr or Mrs. 500
Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)

Group: General Forum Members
Points: 527 Visits: 441
Sorry, I'm not always good at putting my questions down in words.

From msdn.com
"If you are distributing reports within an intranet and you are using an SMTP gateway to a Microsoft Exchange server, type the e-mail alias (as if you were sending e-mail to a coworker)."

The RS automatically populates the email address field with the username of the individual logged on. It is just not working on my current setup and I do not know where to look to resolve this. It has worked for me in the past at other companies I have worked at.
Jeffrey Williams 3188
Jeffrey Williams 3188
SSCoach
SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)

Group: General Forum Members
Points: 19115 Visits: 10042
Find and edit the file rsreportserver.config. Locate the section for the Report Server Email extension. Modify the default host name and permitted host name sections and add your domain information.

Example:


<DefaultHostName>domain.company.com</DefaultHostName>
<PermittedHosts>
<HostName>domain.company.com</HostName>
</PermittedHosts>



Restart Reporting services to pick up the changes.

Jeffrey Williams
Problems are opportunities brilliantly disguised as insurmountable obstacles.

How to post questions to get better answers faster
Managing Transaction Logs

adams.squared
adams.squared
Mr or Mrs. 500
Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)Mr or Mrs. 500 (527 reputation)

Group: General Forum Members
Points: 527 Visits: 441
That did the trick. Thanks
Jeffrey Williams 3188
Jeffrey Williams 3188
SSCoach
SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)

Group: General Forum Members
Points: 19115 Visits: 10042
You are welcome - glad it worked. I just wish MS would expose those settings in the configuration instead of having to find it in the config file. There are other settings available - but I have not reviewed all of them.

Jeffrey Williams
Problems are opportunities brilliantly disguised as insurmountable obstacles.

How to post questions to get better answers faster
Managing Transaction Logs

Jerry Hung
Jerry Hung
Hall of Fame
Hall of Fame (3.5K reputation)Hall of Fame (3.5K reputation)Hall of Fame (3.5K reputation)Hall of Fame (3.5K reputation)Hall of Fame (3.5K reputation)Hall of Fame (3.5K reputation)Hall of Fame (3.5K reputation)Hall of Fame (3.5K reputation)

Group: General Forum Members
Points: 3450 Visits: 1208
Jeffrey Williams (3/25/2009)
Find and edit the file rsreportserver.config. Locate the section for the Report Server Email extension. Modify the default host name and permitted host name sections and add your domain information.

Example:


<DefaultHostName>domain.company.com</DefaultHostName>
<PermittedHosts>
<HostName>domain.company.com</HostName>
</PermittedHosts>



Restart Reporting services to pick up the changes.


did not know this trick, thanks for sharing
will keep this in mind

but for my sake, I always explicitly state the full email address anyway

SQLServerNewbie

MCITP: Database Administrator SQL Server 2005
Jeffrey Williams 3188
Jeffrey Williams 3188
SSCoach
SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)SSCoach (19K reputation)

Group: General Forum Members
Points: 19115 Visits: 10042
Jerry - yes, you can specify the full address yourself because you are an administrator and have that ability. However, a normal user would not have that ability and cannot modify the email to address field - which defaults to only their username.

If you want to give your users the ability to setup and create subscriptions - then you have to specify the default domain. Or (I haven't tried this myself), you can disable the property right above that 'SendEmailToUserAlias'. Not sure if that will work - but, something you can test.

Jeffrey Williams
Problems are opportunities brilliantly disguised as insurmountable obstacles.

How to post questions to get better answers faster
Managing Transaction Logs

p.gibson
p.gibson
SSC Rookie
SSC Rookie (37 reputation)SSC Rookie (37 reputation)SSC Rookie (37 reputation)SSC Rookie (37 reputation)SSC Rookie (37 reputation)SSC Rookie (37 reputation)SSC Rookie (37 reputation)SSC Rookie (37 reputation)

Group: General Forum Members
Points: 37 Visits: 56
Hi (this is my first post)

Like the person who posted this originally, my subscriptions are failing to send an email when just the email alias is used.

Unlike the original post, my organisation's email alias' are not in the same format: aadams to aadams@company.com

In actual fact it goes: aadams to andy.adams@company.com (and the like)

I presume that editing the RSConfig file would be futile in my case.

FYI I'm using SQL Server 2005.

kind regards
Paul
aarnovit
aarnovit
SSC Rookie
SSC Rookie (29 reputation)SSC Rookie (29 reputation)SSC Rookie (29 reputation)SSC Rookie (29 reputation)SSC Rookie (29 reputation)SSC Rookie (29 reputation)SSC Rookie (29 reputation)SSC Rookie (29 reputation)

Group: General Forum Members
Points: 29 Visits: 7
To give the regular users the ability to specify the email address, set the send email to alias value to false:

<SendEmailToUserAlias>False</SendEmailToUserAlias>

The downside is that the user must specify the full email address and they can now email the reports to ANY email address - even those outside your organization. (That may or may not be an issue for you.)
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search