SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


configuration


configuration

Author
Message
saby
saby
SSC-Addicted
SSC-Addicted (457 reputation)SSC-Addicted (457 reputation)SSC-Addicted (457 reputation)SSC-Addicted (457 reputation)SSC-Addicted (457 reputation)SSC-Addicted (457 reputation)SSC-Addicted (457 reputation)SSC-Addicted (457 reputation)

Group: General Forum Members
Points: 457 Visits: 277
hi m having a server brand new server
with 28 GB ram and processor 3ghz * 2
database size 10 GB

when i run sp_configure for max server memory i get this values
config value for sqlserver i think is to high wat are ur suggestions



name minimum maximum config_value run_value
----------------------------------- ----------- ----------- ------------ -----------
max server memory (MB) 16 2147483647 2147483647 2147483647
Mark Sumner
Mark Sumner
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1095 Visits: 456
If your server is only running SQL Server and has no other resource intensive apps running on it reserving 2GB RAM for the OS should be plenty. Therefore, set your maximum memory to 26GB (or 26624MB).
I never bother setting the minimum, but then I don't run multiple instances or other memory intensive apps on my SQL servers. If you do, you may want to consider some monitoring of process | private bytes (in perfmon or process explorer) which indicates the amount of non shared memory reserved by any given process. Then setting a different max for each instance, or a minimum and a max.
Chris_P
Chris_P
SSC Veteran
SSC Veteran (217 reputation)SSC Veteran (217 reputation)SSC Veteran (217 reputation)SSC Veteran (217 reputation)SSC Veteran (217 reputation)SSC Veteran (217 reputation)SSC Veteran (217 reputation)SSC Veteran (217 reputation)

Group: General Forum Members
Points: 217 Visits: 371
Hi,

Are you running a 32 or 64 bit OS/SQL Server combination? Related to your question but not answering it directly. (That was already done)
If you're using 32 bit, you will need to enable the 3GB switch in your boot.ini file as well as AWE to take advantage of any memory over 2 GB.

Chris.

Chris.
saby
saby
SSC-Addicted
SSC-Addicted (457 reputation)SSC-Addicted (457 reputation)SSC-Addicted (457 reputation)SSC-Addicted (457 reputation)SSC-Addicted (457 reputation)SSC-Addicted (457 reputation)SSC-Addicted (457 reputation)SSC-Addicted (457 reputation)

Group: General Forum Members
Points: 457 Visits: 277
m using x64 so i think that is not needed..
Van Heghe Eddy
Van Heghe Eddy
Ten Centuries
Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)

Group: General Forum Members
Points: 1232 Visits: 909
Hi,

Our production server has 4Gb Physical memory
2 x Quad Core Cpu 2.6Mhz

Main database : approx. 1Gb with low load for the moment (busy migrating old application to sqlserver en windev forehand)

I have enabled the /3Gb switch in de boot.ini file but do i also have to enable AWE .?
If so: are there any other setting that should been taken care of .?

Currently sqlserver.exe runs up to 2.2Gb memory usage in taskmanager
Responds from server are lightning fast (but then again, im mostly running in max 5 simultanious users for the moment, will go up to approx. 100 users (batch processing included)

Tnx for any advice regarding this "issue"
wkr
Eddy
nary
nary
SSCommitted
SSCommitted (1.8K reputation)SSCommitted (1.8K reputation)SSCommitted (1.8K reputation)SSCommitted (1.8K reputation)SSCommitted (1.8K reputation)SSCommitted (1.8K reputation)SSCommitted (1.8K reputation)SSCommitted (1.8K reputation)

Group: General Forum Members
Points: 1809 Visits: 1449
By default SQL Server reserve 2 Gb for maximum memory, you have to increase it to your prefered value if there is one lne instance and ther is no other application running on server then 26 gb can be allocated to SQL Server, as it is 64 bit you need not AWE ,/pae. or /3gb switch.
increase the maximum memory setting and restart the SQL Server..
HWH
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search