Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


SSIS, "Class Not Registered" error...deployment or permissions issue?


SSIS, "Class Not Registered" error...deployment or permissions issue?

Author
Message
zhasan
zhasan
Forum Newbie
Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)

Group: General Forum Members
Points: 4 Visits: 36
I am able to run the SSIS package just fine by itself, and I am using my sql account. The issue happens when I add it to the SQL server agent to execute, that's when my package fails.

Any thoughts?

amirhh2000 (3/24/2014)
First of all I hate SSIS2005 ... it has too many bugs ... (preferably use 2008R2 or 2012)

Things you can check are as follows:

1. Make 64bit false
2. Delay validation = False (in the body of package and on all objects)
3. EncreptionMethod = SensitiveWithPassword
4. If you changed number 3 reopen your data connections and re enter username password to be encrypted with the new method.
5. SQL Agent Service account has access to your Excel/Access datafile location
6. Create the SQL Job from SSMS2005 not SSMS2008/2012
7. be patient ... Smile

Cheers
Amir

erinehartjr
erinehartjr
Forum Newbie
Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)

Group: General Forum Members
Points: 1 Visits: 43
I'm not sure if this was ever fixed, but ever time I've run into this error all I've needed to do was load the driver from the following link, and my packages run great.

[url=http://www.microsoft.com/en-us/download/details.aspx?id=13255][/url]
deborah.long
deborah.long
Forum Newbie
Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)

Group: General Forum Members
Points: 1 Visits: 1
It's a two-fold process to over come this error, but both very simple fixes. I used this post to solve the issue. - http://microsoft-ssis.blogspot.co.uk/2012/09/swtich-package-from-64bit-to-32bit.html
intvfan
intvfan
SSC-Enthusiastic
SSC-Enthusiastic (144 reputation)SSC-Enthusiastic (144 reputation)SSC-Enthusiastic (144 reputation)SSC-Enthusiastic (144 reputation)SSC-Enthusiastic (144 reputation)SSC-Enthusiastic (144 reputation)SSC-Enthusiastic (144 reputation)SSC-Enthusiastic (144 reputation)

Group: General Forum Members
Points: 144 Visits: 161
in the lower left of the validate screen is a Check Box to run 32 Bit.
This worked for me!

Changing the setting under DEBUG to 64Bit False did not work for me.
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search