Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Remote Connection to SQL Server from Management Studio Express


Remote Connection to SQL Server from Management Studio Express

Author
Message
Vinit Fichadia
Vinit Fichadia
Grasshopper
Grasshopper (15 reputation)Grasshopper (15 reputation)Grasshopper (15 reputation)Grasshopper (15 reputation)Grasshopper (15 reputation)Grasshopper (15 reputation)Grasshopper (15 reputation)Grasshopper (15 reputation)

Group: General Forum Members
Points: 15 Visits: 56
Hi all,

I m trying to get connected to SQL Server remotely from my machine. I've tried all the steps specified in forums and other questionaires, but still i m not able to get connected to the same. I've rectified all the points such connection strings, named pipes, enabling of remote connection etc.

but still i m getting following error. Please help me resolving the same.



An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: SQL Network Interfaces, error: 25 - Connection string is not valid) (Microsoft SQL Server, Error: 87)

vidhya sagar
vidhya sagar
SSC-Addicted
SSC-Addicted (418 reputation)SSC-Addicted (418 reputation)SSC-Addicted (418 reputation)SSC-Addicted (418 reputation)SSC-Addicted (418 reputation)SSC-Addicted (418 reputation)SSC-Addicted (418 reputation)SSC-Addicted (418 reputation)

Group: General Forum Members
Points: 418 Visits: 620
Hi,

I hope the problem is with connection string, can you post the exact connection string you are using in application or the servername you are using in management studio to conenct.


Regards..Vidhya Sagar
SQL-Articles
anon-272035
anon-272035
Forum Newbie
Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)

Group: General Forum Members
Points: 1 Visits: 7
Have you checked that your SQL Server browser service is running? Ensure that this is in auto start and that it is not stopped.
vareck.walla
vareck.walla
Forum Newbie
Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)

Group: General Forum Members
Points: 5 Visits: 21
If you are connecting through Sql Sever Mgmt Studio, make sure that you put the port number after the IP address. (i.e. xxx.xxx.xx.xx:1433) 1433 typically is the open port, but I usually change mine. If you change it (port #) on your router, then make sure you change it in SQL server. Also make sure that SSMS is using Mixed Mode authentication, not just Windows.

Hope this helps
JamieX
JamieX
Old Hand
Old Hand (371 reputation)Old Hand (371 reputation)Old Hand (371 reputation)Old Hand (371 reputation)Old Hand (371 reputation)Old Hand (371 reputation)Old Hand (371 reputation)Old Hand (371 reputation)

Group: General Forum Members
Points: 371 Visits: 437
You have to do some diagnostics and post results unless you want to just get guessing answers.

on the db server in command prompt do:
telnet localhost 1433

do you get connected, or a "Could not open connection to the host" error?

then on your workstation do:
telnet --servername--1433

get connected?

you can also do a "netstat -a" and look for
TCP servername:ms-sql-s ... LISTENING
bitbucket-25253
bitbucket-25253
SSCertifiable
SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)

Group: General Forum Members
Points: 5695 Visits: 25280
Most unusual - got the same identical error this morning using SSMS. Unusual in that last night about 10 PM all was fine. Decided to shut down my desktop an do a cold boot. And dear old Microsoft displayed the message that my computer was being automatically updated with 5 security updates - yes on the desk top I do subscribe to auto updates.
Let the machine shut itself down and then powered it back up, immediately ran SSMS and surprise no problems... seems that one of the updates was to the named-pipes dll to close some sort of security gap.

If everything seems to be going well, you have obviously overlooked something.

Ron

Please help us, help you -before posting a question please read

Before posting a performance problem please read
MannySingh
MannySingh
SSChasing Mays
SSChasing Mays (649 reputation)SSChasing Mays (649 reputation)SSChasing Mays (649 reputation)SSChasing Mays (649 reputation)SSChasing Mays (649 reputation)SSChasing Mays (649 reputation)SSChasing Mays (649 reputation)SSChasing Mays (649 reputation)

Group: General Forum Members
Points: 649 Visits: 779
Are you trying to connect to SQL 2000 or SQL 2005
Did you try:
From SQL Server Mana Studio, when you click to connect-> click Options and Network Protocols-> Named Pipes.. Check if this works.
else.. Start-> RUN-> cliconfg then disable all Protocols in the right side of the SQL Server Client Network Utility window. then APPLY.
Again First Enable Named Pipes then TCP/IP.. Goto Alias TAB click on ADD, under named Pipes check Just add the SERVERNAME you are trying to conenct and click ok to com out of the window.
Try to connect through SSMS.

Maninder
www.dbanation.com
bfarley
bfarley
SSC-Enthusiastic
SSC-Enthusiastic (192 reputation)SSC-Enthusiastic (192 reputation)SSC-Enthusiastic (192 reputation)SSC-Enthusiastic (192 reputation)SSC-Enthusiastic (192 reputation)SSC-Enthusiastic (192 reputation)SSC-Enthusiastic (192 reputation)SSC-Enthusiastic (192 reputation)

Group: General Forum Members
Points: 192 Visits: 50
Are there any firewall or networking issues that might be causing this failure?
Vinit Fichadia
Vinit Fichadia
Grasshopper
Grasshopper (15 reputation)Grasshopper (15 reputation)Grasshopper (15 reputation)Grasshopper (15 reputation)Grasshopper (15 reputation)Grasshopper (15 reputation)Grasshopper (15 reputation)Grasshopper (15 reputation)

Group: General Forum Members
Points: 15 Visits: 56
thanks you are absolutely right

really appreciated

thank you very much

it worked
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search