SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Log Shipping Secondary Server Restore problem


Log Shipping Secondary Server Restore problem

Author
Message
nisher.nicky
nisher.nicky
SSC Rookie
SSC Rookie (27 reputation)SSC Rookie (27 reputation)SSC Rookie (27 reputation)SSC Rookie (27 reputation)SSC Rookie (27 reputation)SSC Rookie (27 reputation)SSC Rookie (27 reputation)SSC Rookie (27 reputation)

Group: General Forum Members
Points: 27 Visits: 241
Hi,

I am facing the similar problem with my Log-shipping in sql 2005, with one thing additional, the MSDB database is not getting updated, I do not find any entry in the Log_Shipping_primaries and Log_Shipping secondaries tables on the MSDB? Any workthrough?
hendra-880128
hendra-880128
Grasshopper
Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)Grasshopper (14 reputation)

Group: General Forum Members
Points: 14 Visits: 94
Hi all,
I've done POC/testing on log shipping using SQL Server 2005, at first, it worked, but sometimes it failed in the recovery job

I just wanna know, what are the matters that caused log shipping failed ?

As far as I know from this topic, these case can caused log shipping failed to restore :
- If any user connect to secondary database (log shipping DB)
- If doing truncate log file on primary database
- If doing backup transaction log on primary database
- any others... ??

And if it failed to restore the transaction log, what should I do ?
abhishekreddy62
abhishekreddy62
SSC Journeyman
SSC Journeyman (81 reputation)SSC Journeyman (81 reputation)SSC Journeyman (81 reputation)SSC Journeyman (81 reputation)SSC Journeyman (81 reputation)SSC Journeyman (81 reputation)SSC Journeyman (81 reputation)SSC Journeyman (81 reputation)

Group: General Forum Members
Points: 81 Visits: 104
I got the same error long time back . I manually restored the log backup and then started the restore job. That fixed the issue.
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search